Persistant algae - light too strong? - The Planted Tank Forum
 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 01-07-2021, 04:37 AM Thread Starter
Newbie
 
PTrader: (0/0%)
Join Date: Sep 2020
Posts: 3
Persistant algae - light too strong?

I have a 60 gallon planted in which algae has been a constant struggle. I dose 1/8 KNO3 and 1/32 KH2PO4 twice a week and dose Flourish excel every day. My lights are Finnex LEDs, I think they're "Planted+" but I can't find any info on it and have no idea what their output is, but they're only on 7.5 hours per day. Tank is lightly stocked. I'm getting decent growth the way things are now, but algae just grows faster. I clean a good portion off during my weekly 15% water changes but it grows back quickly. It seems to like my wisteria, anubias, and amazon swords the most but doesn't do nearly as well on my pogostemon stellatus 'octopus'.


Is my light just too strong for going without pressurized CO2? I would prefer to just get a less powerful light and go without CO2 if this is the case.

Attached Thumbnails
Click image for larger version

Name:	20210105_201932(1).jpg
Views:	3
Size:	515.1 KB
ID:	906647  

Click image for larger version

Name:	20210105_201912(1).jpg
Views:	3
Size:	451.4 KB
ID:	906649  

romat0 is offline  
Reply

Tags
None

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the The Planted Tank Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome