Algae ID - The Planted Tank Forum
 1Likes
  • 1 Post By Mark Fisher
 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 11-17-2020, 01:44 PM Thread Starter
Algae Grower
 
PTrader: (0/0%)
Join Date: Jun 2020
Posts: 50
Algae ID

Have had this algae on the wood only in a bare bottom turtle tank for a few weeks now, any suggestions?

Water quality is good, only use remineralised RO, good filtration etc.

Have tried jetwashing it off but it comes back, out of water it appears invisible.




Sent from my iPhone using Tapatalk
BS3915 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 11-17-2020, 05:43 PM
Planted Tank Obsessed
 
Mark Fisher's Avatar
 
PTrader: (0/0%)
Join Date: Dec 2011
Location: Rockport, Texas
Posts: 488
Not algae, it's a fungi. Somewhat common on new driftwood:
monster mac likes this.
Mark Fisher is offline  
Reply

Tags
None

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the The Planted Tank Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome