What algae is this? - The Planted Tank Forum
 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 11-05-2020, 11:25 AM Thread Starter
Newbie
 
PTrader: (0/0%)
Join Date: Sep 2020
Location: Bangalore, India
Posts: 1
Hello everyone. I am facing this algae from sometime in my tank and only on the Amazon sword. Any idea what algae is this?Also any suggestions to eradicate will help.

To help the cause here are few details:

Tank Volume - 10 Gallons
Light - LED 14 watts
CO2 - turns indicator lime gree
Filter - Eheim Liberty 200 in photo period. + Fluval C2 rest of the time.
Fertz - Tropica Specialized 1.5 ml per day

More than happy to provide any other information that you may need.
Attached Thumbnails
Click image for larger version

Name:	16045751555373893680793439207305_1604575173800.jpg
Views:	8
Size:	209.3 KB
ID:	904963  

Click image for larger version

Name:	16045752139007159627208116892864_1604575232274.jpg
Views:	8
Size:	310.3 KB
ID:	904965  

sanjoyraju is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 11-05-2020, 05:15 PM
Wannabe Guru
 
PTrader: (0/0%)
Join Date: Sep 2017
Location: Apple Valley, CA
Posts: 1,903
Looks like staghorn to me.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
|
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
varanidguy is online now  
Reply

Tags
None

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the The Planted Tank Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome