What is this algae? - The Planted Tank Forum
 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 07-25-2020, 01:44 AM Thread Starter
Algae Grower
 
PTrader: (0/0%)
Join Date: Jun 2020
Location: NYC
Posts: 77
The new tank.

I THINK this is Sort of hair algae covered in diatoms.
But I’m not sure.

We’ve been manually removing it but it comes back super fast. I’m not even sure how to get it out of moss.

Tank is very new started in late June, fishless cycled, added fish last weekend.

Our lights are on a preset cycle with a Finnex planted + 24/7 - I find lighting most confusing aspect of the hobby.

I’ve not been dosing ferts since we got fish.

I have the aquarium coop pack of easy green, liquid CO2 and iron. Root tabs are in my PFS substrate.

Help?
Attached Thumbnails
Click image for larger version

Name:	BFA3DC99-3C5B-4F40-A113-1925B47AC8C5_1595641433103.jpg
Views:	11
Size:	122.5 KB
ID:	901339  

Click image for larger version

Name:	B09411FA-A82B-40AF-9A55-B2CECD1E3A35_1595641449871.jpg
Views:	12
Size:	146.7 KB
ID:	901341  

Lanaquarium is offline  
Reply

Tags
None

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the The Planted Tank Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome