GSA on all the plants. Help!!!!! - The Planted Tank Forum
 
LinkBack Thread Tools Display Modes
post #1 of 11 (permalink) Old 07-01-2020, 11:48 AM Thread Starter
Algae Grower
 
PTrader: (0/0%)
Join Date: Jul 2020
Posts: 5
GSA on all the plants. Help!!!!!

Hello everyone,

In recent few weeks i m able to see that all my plants are getting covered with GSA, and also there is a stunt growth of all the plants. My Ferns are not having any new growth. Also the lower portion of rotala is getting covered with GSA. Had also tested the Phosphate level and it was showing me between 0.25 to 0.5mg/L.
My fertilizer regime is ADA Green Brighty series. Pressurised CO2 system with 2 bubbles per sec.

I have also attached some photos for reference.
Appreciate your help.
Attached Thumbnails
Click image for larger version

Name:	7A039FE6-95DC-4FBF-A0D5-039B6093EF03_1593604061487.jpg
Views:	29
Size:	258.3 KB
ID:	900449  

Click image for larger version

Name:	6D5B3FF2-071E-47E5-A067-1C5BBA537175_1593604076853.jpg
Views:	30
Size:	220.9 KB
ID:	900451  

Karan Jailwal is offline  
Sponsored Links
Advertisement
 
post #2 of 11 (permalink) Old 07-01-2020, 07:56 PM
Planted Tank Guru
 
DaveKS's Avatar
 
PTrader: (0/0%)
Join Date: Apr 2019
Location: 67212
Posts: 2,343
What is substrate and if ADA soil did you follow the recommended water change schedule for 1st few weeks of tank?
DaveKS is offline  
post #3 of 11 (permalink) Old 07-01-2020, 08:01 PM Thread Starter
Algae Grower
 
PTrader: (0/0%)
Join Date: Jul 2020
Posts: 5
Quote:
Originally Posted by DaveKS View Post
What is substrate and if ADA soil did you follow the recommended water change schedule for 1st few weeks of tank?

Yes its Ada Amazonia with power stand and yes i have followed the WC schedule as per ADA.
Karan Jailwal is offline  
 
post #4 of 11 (permalink) Old 07-02-2020, 01:59 PM
Algae Grower
 
PTrader: (0/0%)
Join Date: Jun 2020
Posts: 5
What test kit are you using for Phosphate? Did you also test for Nitrate level?
Viper.sg is offline  
post #5 of 11 (permalink) Old 07-03-2020, 07:55 AM Thread Starter
Algae Grower
 
PTrader: (0/0%)
Join Date: Jul 2020
Posts: 5
Quote:
Originally Posted by Viper.sg View Post
What test kit are you using for Phosphate? Did you also test for Nitrate level?
I M using API test kits for both Phosphates and Nitrates and my Nitrates are 0PPM
Karan Jailwal is offline  
post #6 of 11 (permalink) Old 07-03-2020, 06:10 PM
Algae Grower
 
PTrader: (0/0%)
Join Date: May 2020
Posts: 66
Quote:
Originally Posted by Karan Jailwal View Post
Quote:
Originally Posted by Viper.sg View Post
What test kit are you using for Phosphate? Did you also test for Nitrate level?
I M using API test kits for both Phosphates and Nitrates and my Nitrates are 0PPM
Your nitrates shouldn’t be 0, especially if you’re dosing ferts . Your plants will be nitrogen limited
fermentedfunk is offline  
post #7 of 11 (permalink) Old 07-10-2020, 01:25 PM
Algae Grower
 
vanostav61's Avatar
 
PTrader: (0/0%)
Join Date: May 2020
Posts: 65
Quote:
Originally Posted by fermentedfunk View Post
Quote:
Originally Posted by Karan Jailwal View Post
Quote:
Originally Posted by Viper.sg View Post
What test kit are you using for Phosphate? Did you also test for Nitrate level?
I M using API test kits for both Phosphates and Nitrates and my Nitrates are 0PPM
Your nitrates shouldn’t be 0, especially if you’re dosing ferts . Your plants will be nitrogen limited
Isn't the ADA soil supposed to leech nutrients into the water? Maybe his test is incorrect?
vanostav61 is offline  
post #8 of 11 (permalink) Old 07-21-2020, 10:13 PM Thread Starter
Algae Grower
 
PTrader: (0/0%)
Join Date: Jul 2020
Posts: 5
Recently i have switched from ADA ferts to EI dosing and now after dosing it shows me phosphate around 1PPM and Nitrates around 40 PPM

Will have to wait and watch the results for few Weeks.
Karan Jailwal is offline  
post #9 of 11 (permalink) Old 07-22-2020, 07:40 PM
Planted Tank Guru
 
DaveKS's Avatar
 
PTrader: (0/0%)
Join Date: Apr 2019
Location: 67212
Posts: 2,343
Quote:
Originally Posted by Karan Jailwal View Post
Recently i have switched from ADA ferts to EI dosing and now after dosing it shows me phosphate around 1PPM and Nitrates around 40 PPM

Will have to wait and watch the results for few Weeks.
You’re nitrate seems excessively high compared to the P level of 1ppm. How are you dosing? Dry dosing or mixing up a solution?

Also are you being sure to aggressively shake the nitrate test reagents before doing test? You can get false readings if you don’t.
DaveKS is offline  
post #10 of 11 (permalink) Old 07-23-2020, 10:37 PM Thread Starter
Algae Grower
 
PTrader: (0/0%)
Join Date: Jul 2020
Posts: 5
I am not dosing dry ferts instead i had made a premixed solution for both macro and micro.

And yes i m mixing the Solution before testing.
Karan Jailwal is offline  
post #11 of 11 (permalink) Old 07-24-2020, 09:16 AM
Planted Tank Guru
 
DaveKS's Avatar
 
PTrader: (0/0%)
Join Date: Apr 2019
Location: 67212
Posts: 2,343
Id say you made a error on the KNO3 portioning of your solution. Are you using spoons or a real digital scale for portions?
DaveKS is offline  
Reply

Tags
None

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the The Planted Tank Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome