Algae after switching nutrients and co2 reg - The Planted Tank Forum
 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 05-05-2019, 04:59 AM Thread Starter
Newbie
 
PTrader: (0/0%)
Join Date: May 2019
Posts: 2
Algae after switching nutrients and co2 reg

Hey all, first time poster. I'm about 3 months into this hobby and am running a 20 gal long high tech planted tank. I was dosing pps but decided to start dry dosing EI. Before switching I was away 3 days and wasn't dosing at all and had cut co2 while waiting for a new regulator to arrive. When I returned and made the switch I noticed some small black growth on my rotala leaves. Right on the edge. This was last week and the stuff is quickly beginning to spread. It doesn't look like BBA to me when I refer to it online however I am still largely inexperienced and am seeking some identification and advice. Thanks allClick image for larger version

Name:	20190430_181327_1557032160360.jpg
Views:	15
Size:	148.4 KB
ID:	881379Click image for larger version

Name:	20190430_181327_1557032160360.jpg
Views:	15
Size:	148.4 KB
ID:	881379
Attached Thumbnails
Click image for larger version

Name:	20190504_091605_1557032233338.jpg
Views:	14
Size:	105.8 KB
ID:	881381  

Warpaint is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 05-07-2019, 04:31 AM
Planted Member
 
PTrader: (0/0%)
Join Date: Jan 2019
Posts: 174
It looks like staghorn. I also had issues when switching to EI. Just make sure your nitrate, phosphate and potassium is truly what you think it is at EVERY DAY for a couple weeks until you get the hang of it. For instance, my phosphate was much lower than it should have been, and my nitrates were way higher due to my fish. You have to measure.

Honestly, I'm still figuring everything out but I have algae at a slow rate with 20-40 ppm nitrate and 2-5ppm phosphate. I dose before the lights and co2 come on every day if needed.

I've noticed that micros with iron (CSM + B) tended to cause staghorn algae when I overdosed on iron as well. Get a hanna iron tester.
Ddrizzle is online now  
post #3 of 4 (permalink) Old 05-07-2019, 12:52 PM
Planted Tank Obsessed
 
PTrader: (0/0%)
Join Date: Jul 2018
Posts: 488
Quote:
Originally Posted by Warpaint View Post
Hey all, first time poster. I'm about 3 months into this hobby and am running a 20 gal long high tech planted tank. I was dosing pps but decided to start dry dosing EI. Before switching I was away 3 days and wasn't dosing at all and had cut co2 while waiting for a new regulator to arrive. When I returned and made the switch I noticed some small black growth on my rotala leaves. Right on the edge. This was last week and the stuff is quickly beginning to spread. It doesn't look like BBA to me when I refer to it online however I am still largely inexperienced and am seeking some identification and advice. Thanks allAttachment 881379Attachment 881379
It's hard to say from your statement what is causing your issues. With most new tanks the #1 culprit is usually light. You also stated you stopped dosing and cut co2, did you cut back on your lighting during this time. What kind of light are you running and for how long? What are your co2 levels? Need more details.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Asteroid is offline  
 
post #4 of 4 (permalink) Old 05-07-2019, 07:23 PM Thread Starter
Newbie
 
PTrader: (0/0%)
Join Date: May 2019
Posts: 2
Quote:
Originally Posted by Asteroid View Post
It's hard to say from your statement what is causing your issues. With most new tanks the #1 culprit is usually light. You also stated you stopped dosing and cut co2, did you cut back on your lighting during this time. What kind of light are you running and for how long? What are your co2 levels? Need more details.
At the time the light remained the same. A Finnex Planted+ light that is on for 7 hours a day. The duration in which its on is still 7 hours. CO2 is at 30 ppm.
Warpaint is offline  
Reply

Tags
None

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the The Planted Tank Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
An Introduction to Algae Specific Nutrients Surf Algae 6 12-28-2017 05:08 AM
Direct vs Indirect Variables to Promote Healthy Prolific, and Algae Free Tanks mfranco General Planted Tank Discussion 1 09-11-2016 02:54 AM
Algae and Nutrient Deficiencies Zapins Algae 15 12-10-2014 08:42 AM
mineralised top soil Ian D Low Tech Forum 13 05-17-2010 02:04 PM
Newbie's First Planted Tank Plan. Suggestions? Tips? Help? Diogenes General Planted Tank Discussion 4 11-24-2009 01:34 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome