Filter Media for Aquaclear 20 - The Planted Tank Forum
 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 07-12-2015, 09:12 PM Thread Starter
Algae Grower
 
PTrader: (0/0%)
Join Date: Jul 2015
Location: Heartland
Posts: 10
Filter Media for Aquaclear 20

I'm setting up a 3 gallon picotope for shrimp, substituting an Aquaclear 20 for the stock filter, as well as replacing the original light with a Finnex FugeRay Planted+ LED clip light. I also have an Hydor 25 watt Theo heater. I'll be using either Fluval Stratum for shrimp or Aqua Soil Amazonia, depending on comments. What kind of filter media should I use? Any tips on cycling? I have well water. Thanks!
Waterdogs is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 07-12-2015, 09:42 PM Thread Starter
Algae Grower
 
PTrader: (0/0%)
Join Date: Jul 2015
Location: Heartland
Posts: 10
Should I heat or light the water as I'm cycling the tank?
Waterdogs is offline  
Reply

Tags
None

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the The Planted Tank Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome