Red Sea Nano Filter Revisions - The Planted Tank Forum
 
LinkBack Thread Tools Display Modes
post #1 of 10 (permalink) Old 03-04-2010, 12:06 AM Thread Starter
Planted Member
 
PTrader: (1/100%)
Join Date: Jun 2004
Location: Portland, OR
Posts: 199
Red Sea Nano Filter Revisions

Found out there are at least two revisions of the Red Sea filter.

Went to Petco and picked up a Red Sea Nano Filter. The filter was dated April 2009. It was very noisy in my tests in a bare tank with tapwater, especially with the lid on the filter. Removed excess molding flash from impeller and made sure there wasn't any crap hidden anywhere. No difference. This was going to sit on my computer desk and would be too annoying. It was louder than my 55 which has three large filters and fans for the lighting.

Swapped it out for another one. This one was dated May 2005. No noise whatsoever from this one.

Things I noticed between them. The older version has a white impeller. The new revision had a green or blue impeller. The new revision also had what I can best describe as a 'filter seeder', a very dense porous white pad that was mounted in a slot that was separate from the sponge/floss filter media. I'm guessing this is retain some bacteria so you don't nuke all the bacteria in the filter when you rinse out or swap the sponge/floss, but it is far too dense to trap any useful amount of particles, the water just flows around it, so I don't know what else it could be for.

So there you have it. You can check the date while in the store by opening the box and looking under the filter. You should be able to see it while it's still in the bag.

Can anyone else check the date on their filter and report whether or not they believe it is 'too noisy'?
sparkysko is offline  
Sponsored Links
Advertisement
 
post #2 of 10 (permalink) Old 03-04-2010, 01:49 AM
Wannabe Guru
 
TLE041's Avatar
 
PTrader: (2/100%)
Join Date: Jan 2010
Location: Canada
Posts: 1,293
Could it be that the filter you returned was a lemon?
TLE041 is offline  
post #3 of 10 (permalink) Old 03-04-2010, 02:11 AM
Moderator
 
Darkblade48's Avatar
 
PTrader: (3/100%)
Join Date: Jan 2008
Location: Toronto/Singapore
Posts: 11,527
I have a Red Sea Nano filter as well, and it is marked July 2007. In addition, it has a blue impeller, so this likely means it is the "new revision."

However, I notice that it is quite quiet; it is sitting on the desk next to my computer, and I cannot hear it when I have my computer on, so...

Anthony


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
and
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Eheim Pimp #362 - Eheim 2213 x2, Eheim 2028, Eheim 2217, Eheim surface skimmer and Eheim autofeeder.
Victor Pimp #33 - HPT272-125-350-4M
Darkblade48 is offline  
 
post #4 of 10 (permalink) Old 03-04-2010, 02:16 AM
Wannabe Guru
 
dj2005's Avatar
 
PTrader: (56/100%)
Join Date: Apr 2009
Location: California
Posts: 1,197
I have the new revision and it is very quiet. It was somewhat noisy using the media that came with the filter, but now I just stuff polyfill in it.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
,
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
,
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
dj2005 is offline  
post #5 of 10 (permalink) Old 03-04-2010, 08:32 AM
Planted Tank Enthusiast
 
PTrader: (20/100%)
Join Date: Oct 2007
Location: New York, NY
Posts: 582
Does anyone have a photo of the new one.. I wonder what the extra media/slot is like.
leviathan0 is offline  
post #6 of 10 (permalink) Old 03-04-2010, 06:00 PM
Planted Member
 
poppyseed's Avatar
 
PTrader: (8/100%)
Join Date: Feb 2010
Location: Pepperell, MA
Posts: 196
I also have one dated April 2009 that I plan on taking back. It's extremely loud and would have spurts of water about every seconds.. but it was just loud in general.
poppyseed is offline  
post #7 of 10 (permalink) Old 03-04-2010, 06:12 PM
Wannabe Guru
 
shane3fan's Avatar
 
PTrader: (14/100%)
Join Date: Nov 2009
Location: Athens Ga.
Posts: 1,245
I have one of the newer ones with the white material that you mentioned. The only noise I hear from mine is when the lid is on it--it kindof vibrates. Ive never done anything to attempt to make it more quiet. The problem I have with mine is if I have the flow control valve all the way open the water will leak out of the back of the filter basket. Ruined an antique hutch with it a few months ago. It wont leak a drop if I slow the flow down, but on full blast it seems to fill the basket faster than it can flow back into the tank?
shane3fan is offline  
post #8 of 10 (permalink) Old 03-04-2010, 06:32 PM
Planted Tank Guru
 
jreich's Avatar
 
PTrader: (3/100%)
Join Date: Feb 2009
Location: philadelphia
Posts: 2,940
Quote:
Originally Posted by shane3fan View Post
I have one of the newer ones with the white material that you mentioned. The only noise I hear from mine is when the lid is on it--it kindof vibrates. Ive never done anything to attempt to make it more quiet. The problem I have with mine is if I have the flow control valve all the way open the water will leak out of the back of the filter basket. Ruined an antique hutch with it a few months ago. It wont leak a drop if I slow the flow down, but on full blast it seems to fill the basket faster than it can flow back into the tank?
i have that problem with a whisper on my 5.5 but luckily if drips right back into the tank.
jreich is offline  
post #9 of 10 (permalink) Old 03-04-2010, 09:43 PM Thread Starter
Planted Member
 
PTrader: (1/100%)
Join Date: Jun 2004
Location: Portland, OR
Posts: 199
Mine hasn't leaked out the back yet, but even without anything to clog the filter the water just rises up and over the sponge/floss.I can raise the sponge/floss to the top, so that it's hitting the lid of the filter, but the water rises with the media.

Do you guys have the media seated on the bottom of the filter, or raised to the top?
sparkysko is offline  
post #10 of 10 (permalink) Old 03-04-2010, 09:51 PM
Planted Tank Guru
 
PTrader: (73/100%)
Join Date: Mar 2009
Location: New York
Posts: 5,942
I have a couple of these for a few years now and they still work very well, but I can confirm what you said sparkysko that it does make some noise with the top on. I just run them 'open-top' lol and it seems fine. I can only hear it when I put my ear right next to it. I have a bag of eheim media on the bottom and on top I have the standard cut yourself blue/white pad.
houseofcards is offline  
Reply

Tags
None

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the The Planted Tank Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome