Issue with DIY co2 and diffuser - The Planted Tank Forum
 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 03-02-2015, 10:02 AM Thread Starter
Algae Grower
 
PTrader: (0/0%)
Join Date: Feb 2015
Location: New York
Posts: 23
Issue with DIY co2 and diffuser

Last night, I started my DIY co2 setup. I have one 2.25 L bottle with 2 cups of sugar and 1 teaspoon of yeast to start my co2 reaction. This bottle is connected to a 500 ml bubble counter which is connected to a new co2 diffuser I bought yesterday. The diffuser is similar to this one.

Initially, I was getting closer a 1 bubble per second and everything was fine. But today morning, the pipe connected to the diffuser has come off. I fixed it but it happened again.

Then I realized currently I am getting atleast 2 bubbles per second, it is due to the pressure built up in the tube that is causing it to unplug. Now I wanna know, whether 2 bps is too much for my diffuser or is there any issues with my diffuser?
lethalbrains is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 03-02-2015, 10:06 AM
Planted Tank Enthusiast
 
Okedokey's Avatar
 
PTrader: (0/0%)
Join Date: Sep 2014
Location: Sydney, Australia
Posts: 784
No issue with defuser, you just need tighter fittings. I would recommend something like this:



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
| Eheim Prof 3, 2217, 2213 (Purigen only) + 350 Skim, Reeflex UV 800 | HC300A Chiller | 3xKessil A360WE LED + Spectral Controller | Pres. CO2 + Aqua Medic Reactor1000 | DIY Fertz + 2 x Jabeo DP-4 | CAL AQUA LABSí Black Earth & GreenBase subst. + root tabs


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
| Eheim 2217 + 2213 | Kessil A360WE LED + Spectral Controller | Pres. CO2 + atomiser | DIY Fertz | ADA Africana + root tabs.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Okedokey is offline  
post #3 of 5 (permalink) Old 03-02-2015, 12:29 PM
Planted Member
 
PTrader: (0/0%)
Join Date: Mar 2014
Location: central texas
Posts: 191
Ive never had a tube come off so i suspect you bought one that is too large. It should take a fair amount of force to get the tube onto the diffuser. Iirc the tube size should be 3/16.
fish jihad is offline  
 
post #4 of 5 (permalink) Old 03-02-2015, 08:42 PM
Banned
 
PTrader: (15/100%)
Join Date: Dec 2013
Posts: 3,261
What size tubing ID? It may be too large for the neck.
Solcielo lawrencia is offline  
post #5 of 5 (permalink) Old 03-04-2015, 05:31 PM
gog
Algae Grower
 
PTrader: (1/100%)
Join Date: Oct 2014
Location: Philly
Posts: 39
Quote:
Originally Posted by Okedokey View Post
No issue with defuser, you just need tighter fittings. I would recommend something like this:

Those look cool do you have a link or an item number?
gog is offline  
Reply

Tags
None

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the The Planted Tank Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome