iAqua: My Touch Interface Aquarium Controller (Arduino) - Page 90 - The Planted Tank Forum
 198Likes
 
LinkBack Thread Tools Display Modes
post #1336 of 2126 (permalink) Old 10-09-2015, 05:39 AM
Algae Grower
 
PTrader: (0/0%)
Join Date: Apr 2015
Location: Danmark
Posts: 9
Now I have tried with a tft shield with components and only with wires (see my post just above) and I only get this screen.
Have seen in previous posts that others have had the same screen, but my being introduced only after I started to use O2's shield (ver. From 09.12.2014).
If I only use Arduino Mega with tft shield and screen works fine with touch screen.
Someone bid on what I might have done wrong.
Attached Thumbnails
Click image for larger version

Name:	IMG_20151009_062543.jpg
Views:	286
Size:	65.4 KB
ID:	526922  


Last edited by prefalch; 10-09-2015 at 10:46 AM. Reason: dredging
prefalch is offline  
Sponsored Links
Advertisement
 
post #1337 of 2126 (permalink) Old 10-10-2015, 01:44 PM
Algae Grower
 
PTrader: (0/0%)
Join Date: Apr 2015
Location: Poland
Posts: 7
Hi
I have problem with PWM.
I have original code iAqua, I changed only line 378, true to false :

Quote:
// if you have a Current Satellite Plus, this is true
// if you are controlling your lights directly with PWM, this is false
boolean lightCSP = false;
I set on the Lights:
High sun - channel blue only
Mid sun - channel cold white only
Low sun - channel white only
moon - turn off
when I'm changing set lights, PWM is working.

I set schedule light:
Moon to low sun 12:00-12:01
Low sun to mid sun 12:02-12:03
Mid sun to high sun 12:04-12:05
High sun to mid sun 12:06-12:07
Mid sun to low sun 12:08-12:09
Low sun to moon 12:10-12:11

I have problem with PWM,light doesn't turn off, light is not change with time.
Do you know what is wrong ?
makonwer is offline  
post #1338 of 2126 (permalink) Old 10-16-2015, 06:12 PM
Newbie
 
PTrader: (0/0%)
Join Date: Aug 2015
Location: trkiye
Posts: 2
hi mrman
Which program do you use for PCBs?
okantekin is offline  
 
post #1339 of 2126 (permalink) Old 10-16-2015, 11:52 PM
Planted Tank Obsessed
 
fietsenrex's Avatar
 
PTrader: (0/0%)
Join Date: Oct 2014
Location: Netherlands
Posts: 421
Quote:
Originally Posted by makonwer View Post
Hi
I have problem with PWM.
I have original code iAqua, I changed only line 378, true to false :



I set on the Lights:
High sun - channel blue only
Mid sun - channel cold white only
Low sun - channel white only
moon - turn off
when I'm changing set lights, PWM is working.

I set schedule light:
Moon to low sun 12:00-12:01
Low sun to mid sun 12:02-12:03
Mid sun to high sun 12:04-12:05
High sun to mid sun 12:06-12:07
Mid sun to low sun 12:08-12:09
Low sun to moon 12:10-12:11

I have problem with PWM,light doesn't turn off, light is not change with time.
Do you know what is wrong ?
does the dimming curve overlap?
also it is a pretty short dimming curve, try to give the curves some more time.
did you get the pin-out correct?
fietsenrex is offline  
post #1340 of 2126 (permalink) Old 10-18-2015, 01:51 AM
Planted Member
 
MrMan's Avatar
 
PTrader: (0/0%)
Join Date: Dec 2014
Location: Vancouver
Posts: 224
Quote:
Originally Posted by okantekin View Post
hi mrman
Which program do you use for PCBs?
Altium Designer

Quote:
Originally Posted by fietsenrex View Post
does the dimming curve overlap?
also it is a pretty short dimming curve, try to give the curves some more time.
did you get the pin-out correct?
He found the same problem with my code and it turned out he had mis-read the ramp length to mean end time so the ramps were set to several hours so they wouldn't have had time to turn on.
MrMan is offline  
post #1341 of 2126 (permalink) Old 10-20-2015, 11:23 AM
Newbie
 
PTrader: (0/0%)
Join Date: Oct 2015
Posts: 2
Hi every one.

Wonder if somebody can assist me with my new project. Purchased a mega R3 2560 board with a Nextion 4.3" TFT display ext. where can I get the latest code?
Gnl_Jakes is offline  
post #1342 of 2126 (permalink) Old 10-20-2015, 04:50 PM
Planted Member
 
MrMan's Avatar
 
PTrader: (0/0%)
Join Date: Dec 2014
Location: Vancouver
Posts: 224
I believe AnotherHobby's code on the first page is a good working version. Or I put my modified version back a couple of pages however the hosting site seems to have lost them. I'll get around to putting mine on Git at some point.
MrMan is offline  
post #1343 of 2126 (permalink) Old 10-23-2015, 04:30 AM
Algae Grower
 
PTrader: (0/0%)
Join Date: Jul 2015
Location: Chicago area
Posts: 17
Quote:
Originally Posted by Gnl_Jakes View Post
Hi every one.

Wonder if somebody can assist me with my new project. Purchased a mega R3 2560 board with a Nextion 4.3" TFT display ext. where can I get the latest code?
Nextion display will not work with this code, it uses serial communication with arduino.
cairo is offline  
post #1344 of 2126 (permalink) Old 10-26-2015, 01:34 PM
Newbie
 
PTrader: (0/0%)
Join Date: Oct 2015
Posts: 2
Quote:
Originally Posted by cairo View Post
Nextion display will not work with this code, it uses serial communication with arduino.
So I will have to start from scratch?

Anybody tried the nextion screen?
Gnl_Jakes is offline  
post #1345 of 2126 (permalink) Old 10-26-2015, 05:56 PM
Algae Grower
 
PTrader: (0/0%)
Join Date: Oct 2015
Posts: 6
Lan connection

Quote:
Originally Posted by MrMan View Post
I've attached the code. It's missing the extra images since the file ends up too large so you can PM me your email and i'll send it. Or if someone can point out where i can upload the PCB/Image files i'll put it there.
Amazing project, just setting up my aquarium and will start assembling this project.
Wondering Alphabet and MrMan if there would be possibility to add ethernet shield/wifi shield, ESP8266 etc?
It would be very handy to see and control aquarium when away with a mobile device or pc connected to Internet.
thank you !
mkcinek is offline  
post #1346 of 2126 (permalink) Old 10-30-2015, 09:47 PM
Planted Tank Obsessed
 
PTrader: (7/100%)
Join Date: Oct 2008
Location: Round Rock, TX
Posts: 363
I've made some progress. Between Digikey sending me the wrong parts, and then the correct parts getting shipped from MN to TX, via Honolulu, I finally got them.

I'm using MrMan's board. He had some extras so I just bought one from him. Putting it together wasn't too bad. I did build a solder reflow oven as many of the parts are SMD. That helped a ton! I couldn't imagine soldering the small tri-state drivers.

I've almost finished the outlets and relay. I used the Mr DJ PCS200 that O2Surplus used. You can get them at Fry's for $25 and they have room for the relay board. You can also use the physical switch as well. I really liked that.

The only other issue I hit was trying to use a 16MB SDCARD. For whatever reason it can't be read by the arduino. So I ended up using a 8GB one I had laying around. Wish I could figure out how to get the small one working

david
Attached Thumbnails
Click image for larger version

Name:	IMG_20151030_154326.jpg
Views:	642
Size:	83.6 KB
ID:	537458  

diztly, diztly, cairo and 5 others like this.
lovingHDTV is offline  
post #1347 of 2126 (permalink) Old 11-02-2015, 01:54 AM
Planted Member
 
MrMan's Avatar
 
PTrader: (0/0%)
Join Date: Dec 2014
Location: Vancouver
Posts: 224
Quote:
Originally Posted by mkcinek View Post
Amazing project, just setting up my aquarium and will start assembling this project.
Wondering Alphabet and MrMan if there would be possibility to add ethernet shield/wifi shield, ESP8266 etc?
It would be very handy to see and control aquarium when away with a mobile device or pc connected to Internet.
thank you !
I don't have any plans to add ethernet/wifi, but the codes there so if you're up to learning Arduino it could be done. Lots of people here that would be willing to help out i'm sure

Quote:
Originally Posted by lovingHDTV View Post
I've made some progress. Between Digikey sending me the wrong parts, and then the correct parts getting shipped from MN to TX, via Honolulu, I finally got them.

I'm using MrMan's board. He had some extras so I just bought one from him. Putting it together wasn't too bad. I did build a solder reflow oven as many of the parts are SMD. That helped a ton! I couldn't imagine soldering the small tri-state drivers.

I've almost finished the outlets and relay. I used the Mr DJ PCS200 that O2Surplus used. You can get them at Fry's for $25 and they have room for the relay board. You can also use the physical switch as well. I really liked that.

The only other issue I hit was trying to use a 16MB SDCARD. For whatever reason it can't be read by the arduino. So I ended up using a 8GB one I had laying around. Wish I could figure out how to get the small one working

david
Looks good! Don't forget to jumper the V+ of the relay signals to either 5V or 12V, that was done so you can use either voltage relay board. If you don't have a proper jumper you could just solder a wire between them.
MrMan is offline  
post #1348 of 2126 (permalink) Old 11-02-2015, 01:59 AM
Planted Tank Obsessed
 
alphabeta's Avatar
 
PTrader: (6/100%)
Join Date: Jul 2014
Location: Chicago Area
Posts: 386
Quote:
Originally Posted by mkcinek View Post
Amazing project, just setting up my aquarium and will start assembling this project.
Wondering Alphabet and MrMan if there would be possibility to add ethernet shield/wifi shield, ESP8266 etc?
It would be very handy to see and control aquarium when away with a mobile device or pc connected to Internet.
thank you !
in principle it is possible, although for that I would probably go with Rasbery Pi, rather than Arduino. Arduino is fine, but the memory is very limited, and it is slow when comes to debugging etc.

46 Bowfront:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

CAPS - Chicago Aquatic Plant Society
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
alphabeta is offline  
post #1349 of 2126 (permalink) Old 11-02-2015, 03:48 PM
Algae Grower
 
PTrader: (0/0%)
Join Date: Aug 2014
Location: Austria
Posts: 13
Quote:
Originally Posted by alphabeta View Post
in principle it is possible, although for that I would probably go with Rasbery Pi, rather than Arduino. Arduino is fine, but the memory is very limited, and it is slow when comes to debugging etc.

Quote:
Originally Posted by alphabeta View Post
in principle it is possible, although for that I would probably go with Rasbery Pi, rather than Arduino. Arduino is fine, but the memory is very limited, and it is slow when comes to debugging etc.
When talking about an ethernet shield, you're right. But mkcinek is also talking about an ESP8266 as well. This is - I'd say the perfect addition.

You can run the whole webserver on this chip - making a Webpage (plain html or better go with websockets) and use it from everywhere (smartphone, browser,..)

For many I/Os, the display, serial in - outs - stay with your arduino - give the data to the esp8266 and runn the webdata there. A perfect combination
NatroN is offline  
post #1350 of 2126 (permalink) Old 11-02-2015, 03:56 PM
Planted Tank Obsessed
 
alphabeta's Avatar
 
PTrader: (6/100%)
Join Date: Jul 2014
Location: Chicago Area
Posts: 386
that's right. Maybe somebody will do that. I have a Raspberry pi on my desk, trying to play around with it, but time, man ... time ...

46 Bowfront:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

CAPS - Chicago Aquatic Plant Society
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
alphabeta is offline  
Reply

Tags
None

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the The Planted Tank Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome