iAqua: My Touch Interface Aquarium Controller (Arduino) - Page 139 - The Planted Tank Forum
 198Likes
 
LinkBack Thread Tools Display Modes
post #2071 of 2124 (permalink) Old 06-06-2019, 11:00 PM
Suspended
 
PTrader: (0/0%)
Join Date: Jun 2013
Location: WI
Posts: 11,588
Quote:
Originally Posted by PickRick View Post
Hi there first and foremost great project . Iv been wanting to do this for a long time but i dont know how to write the code.

Just a question about the leds im using a TC420 controller for my diy led lights but if i can change that by using the arduino that will be awesome.

so you have a little bit more experience in this then me. I have 2x 3watt royal blue leds on one driver and 10 watt white on its own driver . ive made pcbs and it consist of 4 blues and 1 white i have ten of these pcbs that im controlling of the TC 420.

Im only using 3 channels 1 ch for the blues and 2 ch,ch 3 for the white. The idea is 5 whites one half of the tank and 5 whites other half .what im trying to do is have the left side of the tanks whites leds to come on in the morning first with all the blues and in the evening have the right side of the tank white leds on before the night blue comes on.

Thanks in advance

If you using the 5V PWM tap off the TC-420 (basically a pre-programmed Aduino) then there should be no differences..EXCEPT (and since I'm not going through all the specs) if it uses 3.3V at the PWM outputs..
some common drivers like Meanwell LDD-L series won't work w/ 3.3V (see bluefish mini).. some LDD-l's will see meanwell spec sheets..
Most Meanwells specify a PWM frequency of 100Hz to 1KHz..

"A man with a watch knows what time it is. A man with two watches is never sure."
jeffkrol is offline  
Sponsored Links
Advertisement
 
post #2072 of 2124 (permalink) Old 06-14-2019, 08:22 AM
Algae Grower
 
PTrader: (0/0%)
Join Date: Apr 2019
Posts: 5
Need Help with my Iaqua Setup

HI All,

I was able to configure the touch the SDcard with the Audrino mega and mega shield and also run through all the demo test for touch screen and also used the sdcard to load images,now i have added the iaqua sketch and it is just showing me the time and date in the top bar and the rest of the screen is just an black screen.

The sketch compiled and loaded successfully but its has an topn of warning message and as i am not an programmer can any one help me with the error and resolve my issue.

The warning message log is attached .
Attached Files
File Type: zip error_log14062019.zip (11.1 KB, 61 views)
sajin.shivdas is offline  
post #2073 of 2124 (permalink) Old 06-17-2019, 04:08 AM
Algae Grower
 
PTrader: (0/0%)
Join Date: Apr 2019
Posts: 5
Quote:
Originally Posted by sajin.shivdas View Post
HI All,

I was able to configure the touch the SDcard with the Audrino mega and mega shield and also run through all the demo test for touch screen and also used the sdcard to load images,now i have added the iaqua sketch and it is just showing me the time and date in the top bar and the rest of the screen is just an black screen.

The sketch compiled and loaded successfully but its has an topn of warning message and as i am not an programmer can any one help me with the error and resolve my issue.

The warning message log is attached .
I have configured the display using
CTE32_R2 for the utft
mytouch as (6,5,4,3,2)

i have tried calibrating the display and i ran some example sketches which both seem to work perfectly fine (Quickdraw and touch buttons from the utouch library)

any idea what i might be doing wrong and how to fix this as i am just able to see date and time on the top bar.
sajin.shivdas is offline  
 
post #2074 of 2124 (permalink) Old 06-18-2019, 10:40 AM
Algae Grower
 
PTrader: (0/0%)
Join Date: Apr 2019
Posts: 13
@sajin.shivdas
On which Arduino IDE did you compile???
I use 1.8.5 which compile without errors.
vorlon1998 is offline  
post #2075 of 2124 (permalink) Old 06-18-2019, 03:45 PM
Algae Grower
 
PTrader: (0/0%)
Join Date: Apr 2019
Posts: 5
Hi Vorlon,

I am using 1.8.9 version, it is not giving any error though its just warning messages and most of them are mainly related to the raw files, it allows to compile and upload the sketch successfully.
Kindly let me know if i have to change the Arduino 1.8.6 and like to compile it again.

Awaiting for your help and suggestion.
Regards
sajin shivdas
sajin.shivdas is offline  
post #2076 of 2124 (permalink) Old 06-21-2019, 12:05 AM
Newbie
 
PTrader: (0/0%)
Join Date: Jun 2019
Posts: 1
Hello,

i'm using the controller for 2 years and the uC runs perfect.

But an Webinterface / MQTT or something else was very great.
Anyone interested or has someone in use?!

Sorry for my bad english!!

Greetings, Florian.
DichterKajo is offline  
post #2077 of 2124 (permalink) Old 06-22-2019, 08:34 AM
Algae Grower
 
PTrader: (0/0%)
Join Date: Apr 2019
Posts: 5
Hi Vorlon,

Tried it but no luck same issue.

Sajin Shivdas
sajin.shivdas is offline  
post #2078 of 2124 (permalink) Old 07-27-2019, 01:36 PM
Newbie
 
PTrader: (0/0%)
Join Date: Sep 2006
Location: Canada
Posts: 1
Quote:
Originally Posted by DichterKajo View Post
Hello,
i'm using the controller for 2 years and the uC runs perfect.

But an Webinterface / MQTT or something else was very great.
Anyone interested or has someone in use?!
I modified the controller and I use a different LCD 3.5" similar as here that has touch screen. It is still not yet finalized, as I do not plan to use all the features from iAqua.

But having MQTT would be a nice feature, connecting ESP8266 on the serial port of ATMega2560 and exposing all the readings to an MQTT server (maybe home assistant would be a good choice).
xebbmw is offline  
post #2079 of 2124 (permalink) Old 07-27-2019, 07:34 PM
Algae Grower
 
PTrader: (0/0%)
Join Date: Apr 2019
Posts: 13
Mega / ESP8266

You have ESP8266 integrated on Arduino Mega (Arduino MEGA ESP8266). I'm very happy with the progress with Nextion display they update software so now support Anti Aliasing fonts!



BTW:
Still didn't found time to start playing with my modifications But I already receive have iAqua PCB v3.
MQTT is in my todo list ...
vorlon1998 is offline  
post #2080 of 2124 (permalink) Old 09-10-2019, 06:29 PM
Algae Grower
 
Subroto's Avatar
 
PTrader: (0/0%)
Join Date: Mar 2013
Location: Greater Noida, India
Posts: 10
In addition to xebbmw and vorlon1998, a few other posters expressed interest in having a web interface for iAqua. In my view, there are three features that would make this controller "complete": addition of pH monitoring (Atlas Scientific?), a web interface (ESP8266 or ESP32?) and an auto feeder. Has anyone incorporated any of these in his/her version of iAqua? We would love to hear if that is so.

I wonder whether MrMan could be coaxed to "upgrade" his shield to version 3 by adding those features?
Subroto is offline  
post #2081 of 2124 (permalink) Old 10-13-2019, 04:37 PM
Algae Grower
 
Sorcerer's Avatar
 
PTrader: (0/0%)
Join Date: Sep 2019
Posts: 20
Hello all ...

Very good job guys. I'm reading the entire discussion but I've not finished it.

Thank you for sharing.
Regards.
Sorcerer

Hello all ...

Just for fun a little try : the Arduino with the shield and the screen an nothing
more. And it works !!! with some errors about the hardware not found but it works!!!
Good thing.
My screen seems to be the same as the one seen in the post's pictures but it
need to work a specific driver : "UTFT myGLCD(CTE32_R2,38,39,40,41);"
and I do'nt found it in the UTFT doc..... Strange.

Still reading the post.

Regards
Serge

Last edited by Darkblade48; 10-15-2019 at 04:07 AM. Reason: Please use the edit function for back to back posts to keep threads cleaner
Sorcerer is offline  
post #2082 of 2124 (permalink) Old 10-15-2019, 01:12 PM
Algae Grower
 
PTrader: (0/0%)
Join Date: Sep 2018
Posts: 5
hi, i have mount the arduino with TFT shield and a 3.2 240x400 TFT lcd, i put the file raw in the sd card formatted as FAT, upload the program and i have this https://drive.google.com/open?id=16Y...Iip9ls10p4DBt3 what can i do now?
Gray_Wolf is offline  
post #2083 of 2124 (permalink) Old 10-15-2019, 04:07 PM
Algae Grower
 
Sorcerer's Avatar
 
PTrader: (0/0%)
Join Date: Sep 2019
Posts: 20
Hello Gray_Wolf ...

It seems that your program isn't able to load the files from the SDCard.
Why not to put some commands "Serial.print" in "screens" to see what happens ??
Eventually re-format your SD card to be sure ...

Regards
Serge

Last edited by Sorcerer; 10-16-2019 at 04:43 PM. Reason: Grammatical errors
Sorcerer is offline  
post #2084 of 2124 (permalink) Old 10-18-2019, 08:02 PM
Newbie
 
PTrader: (0/0%)
Join Date: Oct 2019
Posts: 1
Lufabbiu is offline  
post #2085 of 2124 (permalink) Old 10-19-2019, 03:27 PM
Algae Grower
 
Sorcerer's Avatar
 
PTrader: (0/0%)
Join Date: Sep 2019
Posts: 20
Hello everyone ...
The drivers of the screen seem not to be involved because as can be seen on the file of his drive Googgle, its screen displays text and graphics.
The only things that are not displayed are the RAW images from its SD card.
The SD Fat library (if different from the one provided) can obviously be tested.
Best regards
Serge
Sorcerer is offline  
Reply

Tags
None

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the The Planted Tank Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome