iAqua: My Touch Interface Aquarium Controller (Arduino) - Page 121 - The Planted Tank Forum
 198Likes
 
LinkBack Thread Tools Display Modes
post #1801 of 2125 (permalink) Old 06-07-2017, 10:50 PM
Algae Grower
 
Le Gui's Avatar
 
PTrader: (0/0%)
Join Date: Jun 2017
Location: France - Brive la Gaillarde
Posts: 13
Quote:
Originally Posted by MrMan View Post
Looks good! I never even noticed that the text on the icons were different, the last few I did myself with my stellar Paint skills, so no surprise they're different. I think you should change the font of the home screen dock to match your icons, and then upload them all so I can use them
I'm working on it!
When finished, I'll post it here so that everyone who want can use it!

Quote:
Originally Posted by AgMa View Post
My modded version:
Nice! Are the dock icons fixed or you can chose in the interface witch icon you want in the dock?
Le Gui is offline  
Sponsored Links
Advertisement
 
post #1802 of 2125 (permalink) Old 06-07-2017, 11:22 PM
Algae Grower
 
AgMa's Avatar
 
PTrader: (0/0%)
Join Date: Jan 2017
Location: Greece
Posts: 95
No, they are fixed.
Dock icons were made from @dkatsariotis, credits go to him
AgMa is offline  
post #1803 of 2125 (permalink) Old 06-08-2017, 04:09 PM
Algae Grower
 
Le Gui's Avatar
 
PTrader: (0/0%)
Join Date: Jun 2017
Location: France - Brive la Gaillarde
Posts: 13
Hi all!

I'm back with good news : dock with new fonts is ready!

Name:  dock.png
Views: 231
Size:  14.2 KB

If you like it, you can download here all pics I have draw:
New font icons
To download : hit the down arrow in the upper right corner of your screen


There are:
-dock 240x66px
-12 icons 48x63px of settings screen (including MISC icon)
-4 round icon 30x30px to replace square ones in "moon" "color" "graph" "misc" screens (upper left corner)
-1 foot icon "reset" for misc screen
-1 square 48x48px PWM icon for the misc screen

Now I am working on "edit" "save" "cancel" "resync" buttons (in LED screen)

If you think there are missing icons with text (ie unused icons for me) : ask me, and I'll draw the icon with same font for you!

Last edited by Le Gui; 09-13-2018 at 08:14 PM. Reason: Modification of file's link
Le Gui is offline  
 
post #1804 of 2125 (permalink) Old 06-24-2017, 05:44 AM
Newbie
 
PTrader: (0/0%)
Join Date: Jun 2017
Posts: 3
Can you please share the source code?
Best regards.

Bump:
Quote:
Originally Posted by Le Gui View Post
Hi everybody!

I'm Guillaume, a french guy that love computers, electronic, and... shrimps!
(sorry for my poor english...)

I have found this thread 2 month ago, what amazing work !

While I wanted to build a similar project, I decided to try to adapt iAqua to my tank, so....

Thanks Dan Cunningham (AnotherHobby), thanks robsworld78, thanks Ryan Truss (MrAqua) and all the others contributors!

I started with the v2.5.1 of MrAqua (thanks again), this code is pretty cool!

I've made my own shield to fit my need (do you think it looks like MrAqua's one? It's normal, I was inspired by it!):
There are 6 outputs with optocouplers for the LED PWM signals


Bottom view (with the PCA9685 SMD):


A view with Arduino Mega:


My mess... :


First launch (dates in french (library modification) and hour in 24h format):


LED WRGB ramp (home made):


I have redraw all the icons to make the texts uniform (note the added MISC button):


For the moment, only 1 more parameter : the possibility to change the PWM frequency in the interface.
Before, PWM freq was "hard stored" in the code (120Hz) and my fish and shrimp were "blinking" on fast movements.
Now, all is visually fixed :


The code is working, but I have some graphic improvements to do...

Now I have to debug 2-3 things, and add new stuff to fit perfectly my needs...



Once again, THANK YOU GUYS FOR THIS WORK !!!
Can you please share the source code?
Best regards.
mmaksiu is offline  
post #1805 of 2125 (permalink) Old 06-25-2017, 09:33 PM
Algae Grower
 
Le Gui's Avatar
 
PTrader: (0/0%)
Join Date: Jun 2017
Location: France - Brive la Gaillarde
Posts: 13
Quote:
Originally Posted by mmaksiu View Post
Can you please share the source code?
Best regards.
Here is my version of iAqua. It is not finished at this time...
I tried to comment most of my modifications.

You can download it here.

I hope it can help!

Otherwise : have some of you tried my icons? Are they readable enough?
Thanks for your returns!
Le Gui is offline  
post #1806 of 2125 (permalink) Old 06-26-2017, 11:02 AM
Algae Grower
 
PTrader: (0/0%)
Join Date: May 2015
Location: Heerlen, The Netherlands
Posts: 25
How did you made the icons? I want to build a PH function.
Matchless is offline  
post #1807 of 2125 (permalink) Old 06-26-2017, 01:33 PM
Algae Grower
 
Le Gui's Avatar
 
PTrader: (0/0%)
Join Date: Jun 2017
Location: France - Brive la Gaillarde
Posts: 13
Quote:
Originally Posted by Matchless View Post
How did you made the icons? I want to build a PH function.
Hi!
I've just made a short tuto for making your own icons.
Just download this archive, and read the readme file!

I hope it can help!
Le Gui is offline  
post #1808 of 2125 (permalink) Old 06-27-2017, 05:08 AM
Newbie
 
PTrader: (0/0%)
Join Date: Jun 2017
Posts: 3
Thank you very much for the code. I will test it in the near future. The icons are readable enough, but I have a 3.5 "tft 320x480 and I paint the icons on x65
mmaksiu is offline  
post #1809 of 2125 (permalink) Old 06-27-2017, 11:56 AM
Planted Tank Obsessed
 
fietsenrex's Avatar
 
PTrader: (0/0%)
Join Date: Oct 2014
Location: Netherlands
Posts: 421
Ugh..
A new problem developed last weekend..
My screen was 100% black, fiddling with the wires didn't do a thing.
So i rebooted it and it got stuck powercycling...
I left it off for some time and booted up flawless.
Yesterday the screen was black again, treid to reboot but failed..
It is now permanent stuck in a power cycle, it was off a full night and this morning still the same issue

Think its in the cap's since i hear a high pitch (charging) humm just before it switches off and restarts.
Something like a jacob's ladder just before the arc leaves it..
fietsenrex is offline  
post #1810 of 2125 (permalink) Old 06-27-2017, 04:53 PM
Algae Grower
 
AgMa's Avatar
 
PTrader: (0/0%)
Join Date: Jan 2017
Location: Greece
Posts: 95
@MrMan
Is it possible to make a newer fritzing schematic with ATO installation?
Thanks a lot!!!
AgMa is offline  
post #1811 of 2125 (permalink) Old 06-27-2017, 08:16 PM
Planted Member
 
MrMan's Avatar
 
PTrader: (0/0%)
Join Date: Dec 2014
Location: Vancouver
Posts: 224
Quote:
Originally Posted by fietsenrex View Post
Ugh..
A new problem developed last weekend..
My screen was 100% black, fiddling with the wires didn't do a thing.
So i rebooted it and it got stuck powercycling...
I left it off for some time and booted up flawless.
Yesterday the screen was black again, treid to reboot but failed..
It is now permanent stuck in a power cycle, it was off a full night and this morning still the same issue

Think its in the cap's since i hear a high pitch (charging) humm just before it switches off and restarts.
Something like a jacob's ladder just before the arc leaves it..
What are you using to power the controller now?

Quote:
Originally Posted by AgMa View Post
@MrMan
Is it possible to make a newer fritzing schematic with ATO installation?
Thanks a lot!!!
Havn't used Fritzing before, but the ATO on my shield is designed for a DC pump so operates the same as the dosing pumps, just an open drain FET.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
MrMan is offline  
post #1812 of 2125 (permalink) Old 06-27-2017, 08:28 PM
Planted Tank Obsessed
 
fietsenrex's Avatar
 
PTrader: (0/0%)
Join Date: Oct 2014
Location: Netherlands
Posts: 421
Quote:
Originally Posted by MrMan View Post
Quote:
Originally Posted by fietsenrex View Post
Ugh..
A new problem developed last weekend..
My screen was 100% black, fiddling with the wires didn't do a thing.
So i rebooted it and it got stuck powercycling...
I left it off for some time and booted up flawless.
Yesterday the screen was black again, treid to reboot but failed..
It is now permanent stuck in a power cycle, it was off a full night and this morning still the same issue

Think its in the cap's since i hear a high pitch (charging) humm just before it switches off and restarts.
Something like a jacob's ladder just before the arc leaves it..
What are you using to power the controller now?
Same 12v power supply as always.
Don't know the brand or anything, it only says 12v 150W
But got it working with first powering the 5v part with a phonecharger on the USB of the arduino and when it was running it "accepted" the 12v.
Managed to do a powercycle and everything is running properly now.
fietsenrex is offline  
post #1813 of 2125 (permalink) Old 06-27-2017, 11:17 PM
Algae Grower
 
AgMa's Avatar
 
PTrader: (0/0%)
Join Date: Jan 2017
Location: Greece
Posts: 95
Quote:
Originally Posted by MrMan View Post


Havn't used Fritzing before, but the ATO on my shield is designed for a DC pump so operates the same as the dosing pumps, just an open drain FET.
Is it powered through the relay or with a mosfet?
And the float switches? What resistors are needed and where?
AgMa is offline  
post #1814 of 2125 (permalink) Old 06-28-2017, 11:22 AM
Algae Grower
 
PTrader: (0/0%)
Join Date: May 2015
Location: Heerlen, The Netherlands
Posts: 25
@fietsenrek

can you measure the power supply?
Open the powermodule and look for defective caps. This is a common problem with chinese power supplies.

And it can kill your arduino or screen!!
So resolve the problem ,do not work around it.
Matchless is offline  
post #1815 of 2125 (permalink) Old 06-28-2017, 11:48 AM
Planted Tank Obsessed
 
fietsenrex's Avatar
 
PTrader: (0/0%)
Join Date: Oct 2014
Location: Netherlands
Posts: 421
Quote:
Originally Posted by Matchless View Post
@fietsenrek

can you measure the power supply?
Open the powermodule and look for defective caps. This is a common problem with chinese power supplies.

And it can kill your arduino or screen!!
So resolve the problem ,do not work around it.
Measure what exactly?
It is cast in resin So replacing something will be hard...

Plan is to resolve the problem since it bugs me that i couldn't pinpoint the cause..
fietsenrex is offline  
Reply

Tags
None

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the The Planted Tank Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome