iAqua: My Touch Interface Aquarium Controller (Arduino) - Page 120 - The Planted Tank Forum
 198Likes
 
LinkBack Thread Tools Display Modes
post #1786 of 2126 (permalink) Old 05-17-2017, 08:53 PM
Planted Member
 
MrMan's Avatar
 
PTrader: (0/0%)
Join Date: Dec 2014
Location: Vancouver
Posts: 224
Quote:
Originally Posted by fietsenrex View Post
Yup, but it is the only thing I have..
Used a fluke 111 now to try and messure the current draw.
But it doesn't show a thing..
Got the positive lead in de A so it should be good to go, set it to DC Amps and tried to messure on the power plug (the one powering the shield)
Or do I need to hook up the fluke in series on one of the power leads?
Yes, you need to hook up the DMM in series with the source to measure current.

Source+ to DMM+
DMM- to Controller+
Controller- to Source-


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
MrMan is offline  
Sponsored Links
Advertisement
 
post #1787 of 2126 (permalink) Old 05-18-2017, 01:24 AM
Algae Grower
 
AgMa's Avatar
 
PTrader: (0/0%)
Join Date: Jan 2017
Location: Greece
Posts: 95
Quote:
Originally Posted by engi View Post
Hi MrMan, thank you for your answer.

Another question :
In your last source code (2.5.1), you write this in the first lines of function setup():

pinMode(48,OUTPUT);
digitalWrite(48,HIGH);

What do you plug on pin 48 ?
@MrMan..
AgMa is offline  
post #1788 of 2126 (permalink) Old 05-18-2017, 04:36 PM
Planted Member
 
MrMan's Avatar
 
PTrader: (0/0%)
Join Date: Dec 2014
Location: Vancouver
Posts: 224
Quote:
Originally Posted by AgMa View Post
Pin 48 isn't used, on my shield it's connected to one of the temp sensor headers but there's no code to use it. Don't remember why it was set high now, probably for debugging something.
lovingHDTV and lovingHDTV like this.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
MrMan is offline  
 
post #1789 of 2126 (permalink) Old 05-20-2017, 12:06 PM
Planted Tank Obsessed
 
fietsenrex's Avatar
 
PTrader: (0/0%)
Join Date: Oct 2014
Location: Netherlands
Posts: 421
Quote:
Originally Posted by MrMan View Post

Yes, you need to hook up the DMM in series with the source to measure current.

Source+ to DMM+
DMM- to Controller+
Controller- to Source-
Got it hooked up.
The controller is running on 0,2A
When i press the test button on the dosingpump it goes up to 0.35A and then drops back to 0.2A

So something is liming the current to the dosingpumps i guess.

Behaviour is the same when using the (old) batterys..
fietsenrex is offline  
post #1790 of 2126 (permalink) Old 05-25-2017, 02:03 AM
Algae Grower
 
NguyenVu's Avatar
 
PTrader: (0/0%)
Join Date: Oct 2016
Location: 77072
Posts: 8
can i used this module 12V is the same picture?
Thanks
NguyenVu is offline  
post #1791 of 2126 (permalink) Old 05-29-2017, 04:40 PM
Planted Member
 
MrMan's Avatar
 
PTrader: (0/0%)
Join Date: Dec 2014
Location: Vancouver
Posts: 224
Quote:
Originally Posted by NguyenVu View Post
can i used this module 12V is the same picture?
Thanks
That's the same one I'm using.
NguyenVu and NguyenVu like this.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
MrMan is offline  
post #1792 of 2126 (permalink) Old 06-01-2017, 08:31 PM
Algae Grower
 
PTrader: (0/0%)
Join Date: May 2017
Location: Meschers sur Gironde
Posts: 7
Hi,

I'm using MrMan last source code version with a Mega board, a TFT screen shield and 3.2 tft lcd (with sdcard reader).
What pins are reserved to screen, to screen shield, and sdcard ?

TIA,
Nicolas

Last edited by engi; 06-01-2017 at 09:06 PM. Reason: error in description
engi is offline  
post #1793 of 2126 (permalink) Old 06-02-2017, 12:58 AM
Algae Grower
 
AgMa's Avatar
 
PTrader: (0/0%)
Join Date: Jan 2017
Location: Greece
Posts: 95
@MrMan

You say that you have disable auto brightness because it never worked well for you, but I can't find anything commented in the code for auto brightness.
How you have disable it?

Last edited by AgMa; 06-02-2017 at 12:59 AM. Reason: edit
AgMa is offline  
post #1794 of 2126 (permalink) Old 06-02-2017, 02:23 PM
Newbie
 
PTrader: (0/0%)
Join Date: Jun 2017
Posts: 1
Quote:
Originally Posted by ODwyerPW View Post
Really enjoying this thread.
A few years back beat my head to get the ColdTears Shield, Font IC, SD, 5" and 7" SSD1963 800X480 LCDs and Arduino DUE (similar to MEGA, but ARM3MX8E based with 3.3v I/O) to build a beautiful front end for my project. Looks like Graham over at Arduino.cc has picked up a few forgotten efforts and nailed allot of this for you all.

I'll be borrowing portions of what you guys are doing here...but with the components I have (Due, 5" LCD, etc..)

My device will not be a controller per se.... Not yet. I'm focused on doing Temp (several), pH, Conductivity, TDS, Salinity, ORP, Dissolved Oxygen, CO2, CO2 dose pressure, Tank Level, Sump Level, Pump Flow, Water Color, Ambient Air Temp / Humid. Basically allot of measuring and analysis. I have all the pieces.. Just need to get going... Enabling wired Ethernet and WiFi will be important ingredients.

Really like the Wide Landscape format someone created for the screen.. Can't remember where I found this example.
Below is my small aluminum enclosure with various pieces parts...
Hi! ODwyerPW!
Do you found a landscape format code?
I was thinking to use Jarduino, then I have prepared a acrillyc case to my reef using landscape format! Now I found iAqua project and need to adapt this!

Thanks.
Cuco is offline  
post #1795 of 2126 (permalink) Old 06-02-2017, 09:25 PM
Planted Member
 
MrMan's Avatar
 
PTrader: (0/0%)
Join Date: Dec 2014
Location: Vancouver
Posts: 224
Quote:
Originally Posted by AgMa View Post
@MrMan

You say that you have disable auto brightness because it never worked well for you, but I can't find anything commented in the code for auto brightness.
How you have disable it?
If you look at the screen settings screen it should say (0=OFF) under auto-dim level. Although my latest version removed it completely and now dims after no button presses after a certain time period.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
MrMan is offline  
post #1796 of 2126 (permalink) Old 06-02-2017, 10:13 PM
Algae Grower
 
AgMa's Avatar
 
PTrader: (0/0%)
Join Date: Jan 2017
Location: Greece
Posts: 95
Quote:
Originally Posted by MrMan View Post
If you look at the screen settings screen it should say (0=OFF) under auto-dim level. Although my latest version removed it completely and now dims after no button presses after a certain time period.
So if I readd it, will it be working again?
Of course with the right hardware.
Do I have to change anything else from the screen menu (for example dim level when touch or autodim seconds)?
AgMa is offline  
post #1797 of 2126 (permalink) Old 06-07-2017, 06:23 PM
Algae Grower
 
Le Gui's Avatar
 
PTrader: (0/0%)
Join Date: Jun 2017
Location: France - Brive la Gaillarde
Posts: 13
Thumbs up Thanks...

Hi everybody!

I'm Guillaume, a french guy that love computers, electronic, and... shrimps!
(sorry for my poor english...)

I have found this thread 2 month ago, what amazing work !

While I wanted to build a similar project, I decided to try to adapt iAqua to my tank, so....

Thanks Dan Cunningham (AnotherHobby), thanks robsworld78, thanks Ryan Truss (MrAqua) and all the others contributors!

I started with the v2.5.1 of MrAqua (thanks again), this code is pretty cool!

I've made my own shield to fit my need (do you think it looks like MrAqua's one? It's normal, I was inspired by it!):
There are 6 outputs with optocouplers for the LED PWM signals
Click image for larger version

Name:	IMG_20170424_204609.jpg
Views:	35
Size:	238.5 KB
ID:	868941

Bottom view (with the PCA9685 SMD):
Click image for larger version

Name:	IMG_20170424_223635.jpg
Views:	44
Size:	271.5 KB
ID:	868943

A view with Arduino Mega:
Click image for larger version

Name:	IMG_20170424_223617.jpg
Views:	44
Size:	258.2 KB
ID:	868945

My mess... :
Click image for larger version

Name:	IMG_20170424_231636.jpg
Views:	42
Size:	252.5 KB
ID:	868947

First launch (dates in french (library modification) and hour in 24h format):
Click image for larger version

Name:	IMG_20170424_231707.jpg
Views:	39
Size:	266.3 KB
ID:	868949

LED WRGB ramp (home made):
Click image for larger version

Name:	IMG_20170427_181745.jpg
Views:	31
Size:	145.2 KB
ID:	868955

I have redraw all the icons to make the texts uniform (note the added MISC button):
Click image for larger version

Name:	IMG_20170607_182139.jpg
Views:	40
Size:	261.7 KB
ID:	868951

For the moment, only 1 more parameter : the possibility to change the PWM frequency in the interface.
Before, PWM freq was "hard stored" in the code (120Hz) and my fish and shrimp were "blinking" on fast movements.
Now, all is visually fixed :
Click image for larger version

Name:	IMG_20170606_200424.jpg
Views:	30
Size:	202.3 KB
ID:	868953

The code is working, but I have some graphic improvements to do...

Now I have to debug 2-3 things, and add new stuff to fit perfectly my needs...



Once again, THANK YOU GUYS FOR THIS WORK !!!

Last edited by Le Gui; 09-13-2018 at 08:09 PM. Reason: Some precisions added
Le Gui is offline  
post #1798 of 2126 (permalink) Old 06-07-2017, 07:21 PM
Planted Tank Obsessed
 
fietsenrex's Avatar
 
PTrader: (0/0%)
Join Date: Oct 2014
Location: Netherlands
Posts: 421
WoW the adjustable PWM is really a nice touch.
I can understand why you want to change it, had some issues with humming LDD's...
Changing the frequency silinced them
fietsenrex is offline  
post #1799 of 2126 (permalink) Old 06-07-2017, 08:34 PM
Planted Member
 
MrMan's Avatar
 
PTrader: (0/0%)
Join Date: Dec 2014
Location: Vancouver
Posts: 224
Quote:
Originally Posted by Le Gui View Post
Hi everybody!

I'm Guillaume, a french guy that love computers, electronic, and... shrimps!
(sorry for my poor english...)

I have found this thread 2 month ago, what amazing work !

While I wanted to build a similar project, I decided to try to adapt iAqua to my tank, so....

Thanks Dan Cunningham (AnotherHobby), thanks robsworld78, thanks Ryan Truss (MrAqua) and all the others contributors!

I started with the v2.5.1 of MrAqua (thanks again), this code is pretty cool!


I have redraw all the icons to make the texts uniform (note the added MISC button):

Looks good! I never even noticed that the text on the icons were different, the last few I did myself with my stellar Paint skills, so no surprise they're different. I think you should change the font of the home screen dock to match your icons, and then upload them all so I can use them


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
MrMan is offline  
post #1800 of 2126 (permalink) Old 06-07-2017, 09:47 PM
Algae Grower
 
AgMa's Avatar
 
PTrader: (0/0%)
Join Date: Jan 2017
Location: Greece
Posts: 95
My modded version:
AgMa is offline  
Reply

Tags
None

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the The Planted Tank Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome