Diy Co2 - The Planted Tank Forum
 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 02-16-2008, 10:20 PM Thread Starter
Planted Member
 
justari's Avatar
 
PTrader: (50/100%)
Join Date: Feb 2008
Location: Southeastern PA
Posts: 168
Diy Co2

this might be on this forum somewhere, but i need directions on how to build a DIY CO2 system. recently i had thought that my CO2 system broke, but before throwing it in the trash i replaced the sugar/yeast in its container and it worked for 1 day and today no reaction is taking place.

system:

http://www.thatpetplace.com/pet/group/243/product.web

Refill:

http://www.thatpetplace.com/pet/group/11113/product.web

is there anything i could use from this system if i do a DIY CO2 system? could anybody recommend any sites that show/teach you how to build one? please hurry!
justari is online now  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 02-16-2008, 10:43 PM
Planted Tank Guru
 
eyebeatbadgers's Avatar
 
PTrader: (62/100%)
Join Date: Aug 2007
Location: Hendersonville, TN
Posts: 2,485
Send a message via AIM to eyebeatbadgers
I like this link.

Why do you think yours is broken?

The sugar yeast mixture doesn't last forever... you'll need to replace it about every two weeks.

If no gas is coming out after 24 hours, check for leaks first, then buy yeast from a different place. I've gotten a couple of bad packs here and there.

HTH


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
eyebeatbadgers is offline  
post #3 of 4 (permalink) Old 02-16-2008, 11:40 PM Thread Starter
Planted Member
 
justari's Avatar
 
PTrader: (50/100%)
Join Date: Feb 2008
Location: Southeastern PA
Posts: 168
no, i dont think my system is broken. sometimes it gets an airlock, but usually i can fix it by tilting the venturi pump upwards.the last two times nothing seems to work. i replaced the mixture 2 days ago.
justari is online now  
 
post #4 of 4 (permalink) Old 02-16-2008, 11:55 PM
Algae Grower
 
PTrader: (0/0%)
Join Date: Oct 2007
Location: Muskego, Wisconsin
Posts: 27
Hello, I have one of these systems as well. A few things to consider.

First, I think the volume of the jug they give you is too small. I replaced it with a 2 liter soda bottle, and I get a lot more gas out.

Secondly, I did not have a lot of luck with their mix. I am not sure why, but it did not seem to work very well. I tried a few variations, but what I have kind of settled on is using 6 cups of dechlorinated tap water, 1 cup of cane sugar, and 1/2 teaspoon of Fleischmans's yeast. This tends to work for close to two weeks, but I usually replace it at about the 10 day mark due to smell.

The final thing is that the venturi can get dirty. If this happens it might not be pulling as much gas into the water as it should.

Mark Koelsch
markkoelsch is offline  
Reply

Tags
None

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the The Planted Tank Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome