Ok it's time to get serious: Karlo's 75G! - The Planted Tank Forum
 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 06-02-2009, 08:01 AM Thread Starter
Algae Grower
 
Karlo's Avatar
 
PTrader: (0/0%)
Join Date: Aug 2008
Location: Hawaii
Posts: 45
Send a message via AIM to Karlo
Red face Ok it's time to get serious: Karlo's 75G!

I took a dive into the world of salt water for a while and didn't have a lot of success. It was a 75G FOWLR with a 20g sump and 30lbs of live rock. I ran it for 4 months and I felt like I was just getting by. After a recent crash and death I decided to break it down and clean everything up.

Now I have a 75G which I plan on turning into a lightly planted community tank with a good variety of fish. Here's a list of equipment I already have from my previous planted tank endeavors.

Fluval 205
Icap Ballast with 2x 48w (actinic and 6700k)
Milwaukee co2 system with glass diffuser.
2bags of ADA amazonia II from another planted tank. (incredibly nasty stuff, how should I clean it?)
2x Hydor Koralia 2
Small UV sterilizer.

I plan on getting the following equipment to add

Filstar XP2
Pool Filter Sand (possibly over amazonia II?)
new bulb, 10,000k?

If I am gonna reuse the amazonia II I really need to blast it, i mean its really really nasty.

How should I sterilize it?

I'm also planning stocking. Will post that soon.

maybe its the heat in here, maybe its the pressure
you ought to head for the exits, the sooner the better
Karlo is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 06-02-2009, 12:11 PM
Algae Grower
 
PTrader: (0/0%)
Join Date: Jan 2008
Location: AR, USA
Posts: 27
You do not want to sterilize your amazonia per say, but you should get it into a bucket, drop that into your tub, and run your hose or the tub faucet into your bucket. Blast out all the floaty crap with that until it runs out reasonably clear. This can take anywhere from 10 minutes to over an hour so be prepared to be at it awhile.

Oh, and welcome back to planted freshwater! I tried SW too on a small pico tank but the price and daily maintenance on it quickly turned me off that aspect of the hobby, and when the power died and killed everything in the tank I cant say I wasnt a little relieved. Good luck to you.
da1001 is offline  
post #3 of 4 (permalink) Old 06-02-2009, 05:50 PM
Planted Tank Obsessed
 
PTrader: (11/100%)
Join Date: Jun 2008
Location: martville, NY
Posts: 463
Send a message via AIM to chuukus
Dont wash Aquasoil just put it into the tank gently so you dont mush it up. When I start a tank with aquasoil I slowly add water just to the top of the substrate then let it sit like that 24 hrs before I add the rest of the water. There might be a few small twigs and peices of wood floating just net it out.

Ohh and you cant cover aquasoil with sand it will just settle to the bottom.
chuukus is offline  
 
post #4 of 4 (permalink) Old 06-02-2009, 10:00 PM Thread Starter
Algae Grower
 
Karlo's Avatar
 
PTrader: (0/0%)
Join Date: Aug 2008
Location: Hawaii
Posts: 45
Send a message via AIM to Karlo
the aquasoil I has had heavy use for a long time. its full of rotted leaves and roots and all kinds of nasty crap. Its sitting in a bucket of water right now. I only have enough to cover 3-4 inches in my 29g and I don't feel like paying $50 a bag again.

maybe its the heat in here, maybe its the pressure
you ought to head for the exits, the sooner the better
Karlo is offline  
Reply

Tags
None

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the The Planted Tank Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome