Journal: My first aquarium, 75 gallon planted tank. - The Planted Tank Forum
 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 03-28-2014, 12:56 AM Thread Starter
Planted Tank Guru
 
philipraposo1982's Avatar
 
PTrader: (0/0%)
Join Date: Mar 2014
Location: Ontario, Canada
Posts: 3,020
Journal: My first aquarium, 75 gallon planted tank.



This is where I will be posting all info regarding my tank and its process. Today I got the tank up and running, sorta. Still needs plants and fish but we will get there.

I will be using ATM Colony to help start things off with a school of Rummy Nose Tetra's. Plants will be going in as soon as I can find some good deals on plants



Since this is my first ever aquarium and as suggested by the people on this forum I have decided to log my process in hopes to not only reflect back on decisions I have made and the mistakes along the way. This is also a great way for other who enter into the hobby to have a look at how others have done it from start to finish

Equipment:
-75 gallon tank
-Eheim pro 3 2075 filter
-Eheim jager 300W heater
-Finnex led planted plus light

Substrate:
-Safe-T-Sorb (approx. 60 lbs used)

Ferts:
-n/a (still doing research on how I want to dose)

Driftwood:
-3 found pieces of driftwood down by lake Ontario, boiled and soaked then screwed to 12x24 pieces of slate which has been buried by the substrate.

Plants:
-

Stocking List:
-25 Red Cherry Shrimp
-10 Oto Catfish
-2 German Blue Ram
-12 Rummy Nose Tetra

Random info:

I thought I would try and just dump the substrate (safe t sorb) right in with out a rinse to see how bad things would get. The picture I posted is that of my tank 1 hour after filling it with water; as you can see its not that bad at all!

Also note that the driftwood I found and did a quick boil and rinse and it went in the tank; no scrubbing or soaking for weeks. Again keep in mind I have it bolted to 2 big 24 x 12 sheets of slate which is under all the substrate. I don't really like the idea of how high the substrate is in the front due to the 1/2 inch slate under it. I may reduce the amount of substrate by 3/4 inch tomorrow or before plants go in.
philipraposo1982 is offline  
Reply

Tags
None

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the The Planted Tank Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome