The Planted Tank Forum - View Single Post - Has anyone tried Landen aquatic soil? Feedback?
View Single Post
post #14 of (permalink) Old 04-21-2020, 05:02 PM
burr740
Planted Tanker
 
burr740's Avatar
 
PTrader: (132/100%)
Join Date: Feb 2014
Location: Bama
Posts: 5,859
Quote:
Originally Posted by zivvel View Post
I didn't get to the Landen tank WC until Sunday, and I changed 57%. Ammonia is 1.5ppm again today, and nitrates 30ppm -- I dosed NO3 & PO4 after WC, but I hadn't measured anything.

@burr740 I recall reading about your AS vs. PO4 battle, but I did not realize the same would happen with Landen. Have you also seen massive ammonia spikes with it? (Did you ever buy an ammonia test kit?)

Have you had any bags of Landen that produce dust when you flood them or move stems around?

Based on your experience, I'm going to ramp up my PO4 dosing even further post-WC. I was doing 3ppm post-WC, and I was planning to dose 1.5ppm 3x/week now that I'm moving to weekly WC. I'm going to try 10ppm post-WC and see where it goes.

Haha I did finally break down and grab some ammonia dipsticks but thats the extent of it. The latest 75 with Landen hit around 1.5- 2 ppm every couple of days for about 2.5 weeks. Then all of a sudden stopped, it went from that to zero in one day and never showed up again. Probably a lot to do with the cycle maturing. No fish so I wasnt too worried about what it did besides melting sensitive plants. More idle curiosity than anything

None of my Landen has been dusty at all, either at first or a few months later. Think Ive used a total of 11 bags so far


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.





Last edited by burr740; 04-21-2020 at 05:57 PM. Reason: .
burr740 is offline  
 
 
For the best viewing experience please update your browser to Google Chrome