The Planted Tank Forum - View Single Post - Has anyone tried Landen aquatic soil? Feedback?
View Single Post
post #4 of (permalink) Old 10-22-2019, 08:23 PM
somewhatshocked
Obsessed? Maybe
 
somewhatshocked's Avatar
 
PTrader: (501/100%)
Join Date: Aug 2011
Location: Middle America
Posts: 14,853
It's not that old, @Hojae84. Thanks for sharing your experience.

I've had two separate batches of it (one obtained via Amazon, another from a shop in the DC area) and have found it to be... average. Takes a lot of it to maintain buffering capacity and nutrient content appears to vary drastically from batch to batch. One batch I have grew really nice crypts and bacopa. The other didn't do much at all.

Both of my batches leeched ammonia at varying points. One tank was about 2PPM for a couple weeks and the other was about 4PPM for 7-8 days.

I'd use it again if someone gave it to me but I wouldn't pay for it when there are better, more affordable products readily available.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
|
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
|
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
|
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
|
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
|
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
|
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
|
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

somewhatshocked is online now  
 
 
For the best viewing experience please update your browser to Google Chrome