K2SO4 question. - The Planted Tank Forum
 
LinkBack Thread Tools Display Modes
post #1 of 6 (permalink) Old 12-03-2015, 11:28 PM Thread Starter
Algae Grower
 
PTrader: (3/100%)
Join Date: Apr 2015
Location: nashville, TN
Posts: 62
K2SO4 question.

did they remove pottasium sulphate k2SO4 from EI dosing stock calculator?
https://www.thenutrientcompany.com/a...calculator/???

i am used to EI dosing with stock solution and i bought the EI dosing package from GLA.
This calculator usually tells me to prepare macro with 3 chemicals
Potassium Nitrate (KNO3)
Mono Potassium Phosphate (KH2PO4)
Potassium Sulfate (K2SO4)

Last time i prepared the solution it had all 3 chemicals, that i am sure. right now it just lists KNO3 and KH2PO4. So what happens to K2SO4?
I prepare it with 500 ml stock solution

I am afraid my stock might now be low on potassium from K2SO4

Last edited by saty; 12-04-2015 at 01:06 AM. Reason: added clarification
saty is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 12-04-2015, 07:49 PM Thread Starter
Algae Grower
 
PTrader: (3/100%)
Join Date: Apr 2015
Location: nashville, TN
Posts: 62
anyone?
saty is offline  
post #3 of 6 (permalink) Old 12-04-2015, 08:02 PM
Planted Tank Enthusiast
 
Mathman's Avatar
 
PTrader: (1/100%)
Join Date: Apr 2009
Location: Los Angeles, CA
Posts: 530
To my understanding, the amount of Potassium needed is usually taken care of by the addition of potassium nitrate. However, there are times when we dose less kno3 since our bio load (fish and/or feeding) is high, in this case we need to dose k2so4 to compensate for the lack of potassium.

Do a search on zorfox's nutrient calculator. It's a Windows based program. Awesome calculator that you can download and not rely on the Internet.
Mathman is offline  
 
post #4 of 6 (permalink) Old 12-04-2015, 08:19 PM Thread Starter
Algae Grower
 
PTrader: (3/100%)
Join Date: Apr 2015
Location: nashville, TN
Posts: 62
thanks. I will try it out when i get home.
Reason why I am little worried is because i see Green spot algae over the period of 14 days.
I clean the back side of the tank only once every other week(for RCS shrimp to graze on if there is any algae film) and at times i see small green spots.
I just read that GSA is the indicator of potassium deficiency, so if my tank was already deficient of potassium with the removal of K2SO4 from my stock solution wouldn't it become even more worse?

Last edited by saty; 12-04-2015 at 08:21 PM. Reason: typo
saty is offline  
post #5 of 6 (permalink) Old 12-04-2015, 08:48 PM
Planted Tank Enthusiast
 
Mathman's Avatar
 
PTrader: (1/100%)
Join Date: Apr 2009
Location: Los Angeles, CA
Posts: 530
Some people have had good results increasing their dose of phosphates when dealing with GSA. Maybe you have are confused thinking its potassium.
Mathman is offline  
post #6 of 6 (permalink) Old 12-04-2015, 10:02 PM
Planted Tank Enthusiast
 
PTrader: (2/100%)
Join Date: Nov 2008
Location: Morgan Hill, CA
Posts: 791
My well water is already 40-50ppm KNO3, so I don't dose it. I instead dose K2SO4. I'm no EI guru, but this is what was recommended to me years ago when I got started with EI.

Also, K2SO4 doesn't dissolve very well. You can only add about 2 tsp per cup of water. Since my tank requires about 1 tsp per week, I just put it in the tank dry.
cjp999 is offline  
Reply

Tags
None

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the The Planted Tank Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome