Help: Adding Iron to PPS Pro - The Planted Tank Forum
 2Likes
  • 2 Post By nilocg
  • 2 Post By plantbrain
 
LinkBack Thread Tools Display Modes
post #1 of 6 (permalink) Old 10-14-2015, 06:45 PM Thread Starter
Planted Member
 
BigXor's Avatar
 
PTrader: (3/100%)
Join Date: Dec 2014
Location: Pennsylvania, USA
Posts: 227
Help: Adding Iron to PPS Pro

How much Iron Chelate 10% do I add to PPS Pro solution.

I have been adding 5.7 grams to 500ml of solution. I don't know if this is enough or too much for my Swords and Rotala.

Edit: This would be in addition to whatever is in Plantex CSM-B


“I wear a ten-gallon cowboy hat. That’s where I keep my fish tank."

Last edited by BigXor; 10-14-2015 at 06:58 PM. Reason: Content
BigXor is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 10-14-2015, 09:50 PM
Planted Tank Guru
 
PTrader: (538/100%)
Join Date: Jul 2010
Location: Oregon
Posts: 3,009
How much are you wanting to add? I believe that PPS-PRO addes about 0.1ppm with each dose, do you want to add another 0.1ppm? What size tank?
nilocg is offline  
post #3 of 6 (permalink) Old 10-14-2015, 10:10 PM Thread Starter
Planted Member
 
BigXor's Avatar
 
PTrader: (3/100%)
Join Date: Dec 2014
Location: Pennsylvania, USA
Posts: 227
Quote:
Originally Posted by nilocg View Post
How much are you wanting to add? I believe that PPS-PRO addes about 0.1ppm with each dose, do you want to add another 0.1ppm? What size tank?

I'm really not sure if I need to add any. There may be enough in the CSM-B. I have read that swords and rotala like iron, so do I need more than the 0.1ppm in the Plantex?

“I wear a ten-gallon cowboy hat. That’s where I keep my fish tank."
BigXor is offline  
 
post #4 of 6 (permalink) Old 10-14-2015, 10:13 PM
Planted Tank Guru
 
PTrader: (538/100%)
Join Date: Jul 2010
Location: Oregon
Posts: 3,009
Its hard to say if you need more or not. Signs of iron deficiency show up in new leaves and will be the following:
Pale growth of new leaves
Leaves can become brittle
Yellowing of leaves
BigXor and BigXor like this.
nilocg is offline  
post #5 of 6 (permalink) Old 10-14-2015, 10:18 PM
Planted Tank Guru
 
plantbrain's Avatar
 
PTrader: (267/100%)
Join Date: Dec 2003
Location: The swamp
Posts: 13,609
There's hardly any plant biomass in the tank............so you are not likely going to run low on anything at the moment.

Frequent dosing and water changes will get you much farther along. Adding CO2 gas? Excel?
Light type?



BigXor and BigXor like this.

Regards,
Tom Barr
plantbrain is offline  
post #6 of 6 (permalink) Old 10-14-2015, 10:29 PM Thread Starter
Planted Member
 
BigXor's Avatar
 
PTrader: (3/100%)
Join Date: Dec 2014
Location: Pennsylvania, USA
Posts: 227
Quote:
Originally Posted by plantbrain View Post
There's hardly any plant biomass in the tank............so you are not likely going to run low on anything at the moment.

Frequent dosing and water changes will get you much farther along. Adding CO2 gas? Excel?
Light type?

I just planted the swords and they are not firmly established in the substrate. I'm injecting CO2, and there is medium light. I run a single T5HO 4000k bulb for 12 hours for visual illumination and two T5HO 6500k lamps for 7 hours in between for plant growth.

“I wear a ten-gallon cowboy hat. That’s where I keep my fish tank."
BigXor is offline  
Reply

Tags
None

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the The Planted Tank Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome