Nutrient deficiency? - The Planted Tank Forum
 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 10-04-2015, 10:16 PM Thread Starter
Newbie
 
PTrader: (0/0%)
Join Date: Oct 2015
Location: Pleasant hill, CA
Posts: 1
Nutrient deficiency?

Sorry if this is in the wrong place, it's my first post here.
I have a 36 gallon low tech tank with a rosette sword and some crypt wendtii that seems to have a nutrient deficiency.
Lighting is 2 22" (I think) t5 ho lamps
The sword's older leaves are turning a mottled yellow one by one while the new leaves are stunted and slightly wrinkled, though still completely green.
The crypts older leaves are dying one by one and after death have dark green stripes running across the leaf that is definitely not algae.
Both plants are next to api root tabs that are less than 2 months old (though they were in the packs for a long time before that) I also add about 3 ml of flourish comprehensive after my weekly pwc's
I don't have time to post pics right now or test water params but will do so later tonight if requested.
What is going on and how do I fix it?
Kfite11 is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 10-05-2015, 12:32 AM
Planted Tank Enthusiast
 
Argus's Avatar
 
PTrader: (0/0%)
Join Date: May 2013
Location: California
Posts: 584
Crypts typically put roots up into the water when they don't get enough nutrients.



I think excessive nutrients might be the problem. Check nitrates and ammonia. It would also be good to know the other parameters to make sure nothing is way off.

What kind of substrate do you have?
Argus is offline  
post #3 of 3 (permalink) Old 10-05-2015, 12:59 AM
Planted Tank Obsessed
 
plantetra's Avatar
 
PTrader: (0/0%)
Join Date: May 2014
Location: West Bloomfield, MI
Posts: 380
This might help if it is a deficiency
Attached Thumbnails
Click image for larger version

Name:	plantdeficiencylabeled_Mar15_2010.jpg
Views:	33
Size:	76.1 KB
ID:	525433  



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
plantetra is offline  
Reply

Tags
None

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the The Planted Tank Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome