Cloudy water + UV Sterilizer - The Planted Tank Forum
 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 09-17-2009, 05:24 AM Thread Starter
Planted Tank Enthusiast
 
rwong2k's Avatar
 
PTrader: (2/100%)
Join Date: Dec 2004
Location: Coquitlam,BC
Posts: 509
Cloudy water + UV Sterilizer

Hello All,

I set up a new tank about 2 months ago with the filters seeded with media from my other tank.
It's been cloudy ever since, so I decided to try out a UV sterilizer.

within 3 days the tank was crystal clear but after the 6th day the tank is cloudy again with teh uv sterilizer on,

any ideas?

it's well planted, 95 gallon tank
nitrates, ammonia are within the normal levels and co2 is around 25ppm,
there's no algae problem except for some spot algae on the glass which is cleared using a razor blade
Just did a 2x 50% water change and here are some of the pix of the aquarium

here's some pictures:
http://rwaquariumpages.blogspot.com/

thank-you
Raymond
rwong2k is offline  
Reply

Tags
None

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the The Planted Tank Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome