Possible flourish interaction with fish? - The Planted Tank Forum
 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 04-25-2015, 11:39 PM Thread Starter
Planted Member
 
PTrader: (0/0%)
Join Date: Sep 2010
Location: NE
Posts: 176
Possible flourish interaction with fish?

Hey all, was curious if anyone has experienced problems using Seachem Flourish with fish. I just started using this after water changes in conjunction with API Leafzone. I am doing a half dose of the leaf zone and since the tank is only 20 gallons I am doing one drop per gallon of the Flourish. I did a 25 percent water change (used stress coat water conditioner) and added the API. No problems. Then this evening I added the Flourish. Randomly my fish are acting like they are twitchy and have parasites.

I don't want to flip out and do another water change in that I might stress them out more. We have had some barometer swings in the last 24 hours and my fish always get goofy when it does but this is more like a weird caffeine twitch within minutes of adding the Flourish. This is NOT Flourish Excell. Just the standard Flourish for micro ferts.

Thanks for any insight.
monty67 is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 04-26-2015, 01:59 AM
Planted Tank Guru
 
PTrader: (3/100%)
Join Date: Aug 2014
Location: Maryland, USA
Posts: 2,339
I've not seen any adverse reactions from my fish or snails, even using flourish at slightly over 2x label rates, which is what is needed to get to EI low-light dosing levels.

The label rates are really quite low doses.. I doubt they'd harm even the most sensitive tank critters...

See also: This discussion of dosing it with shrimp, which are notoriously more sensitive to fertilizers than fish...

https://www.plantedtank.net/forums/sh...d.php?t=156309

And this one:
https://www.plantedtank.net/forums/sh...ad.php?t=44184

New to planted tanks, avid gardener/tinkerer.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Fluval C4 + Quietflow 30, Finnex Planted+ with
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
, low-tech.
10 gallon secondary tank with Finnex stingray with
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
, AC20, low tech
mattinmd is offline  
post #3 of 3 (permalink) Old 04-26-2015, 03:40 AM Thread Starter
Planted Member
 
PTrader: (0/0%)
Join Date: Sep 2010
Location: NE
Posts: 176
Ok, cool, I appreciate it. Did a brief search but didn't see these. I guess I will just keep an eye on the fish then, seems like it was mainly the gold tetras I have. The rest of the tank seemed unaffected. Maybe they were just in a mood. Everyone appears pretty healthy though.
monty67 is offline  
Reply

Tags
None

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the The Planted Tank Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome