New to planted tank Ferts - The Planted Tank Forum
 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 08-13-2014, 02:32 AM Thread Starter
Planted Tank Obsessed
 
Gavin Citrus's Avatar
 
PTrader: (0/0%)
Join Date: Aug 2014
Location: St. Louis, Missouri
Posts: 378
New to planted tank Ferts

So I did a lot of reading and now am starting to rethink the situation.

So I set up my tank as a MGOPM capped with Black Diamond, thinking I was going to get most ferts from the soil itself and not have to worry about ferts early. However the more I read the more I believe I need to be dosing the water column (I'm sure you'll tell me that's easy).

It's a 60 gallon, it's in the middle of a fishless cycle, although there are a couple shrimp in the tank.

I'm about two weeks in with a large area of DHG, with a few Crypt wendtii, one anubias, one echinodorus, two java ferns, some rotala indica. I have a lot of other plants on their way.

I've read some stuff on the EI and wondered if that's what I need to be doing? Also where do I go about buying the proper ferts, in general I see recommendations but am not sure about finding them?

Is there any general one I Can use temporarily that fill most needs (Flourish?) until I figure out a better schedule?

I definitely am not prepared ferts wise.

I have a 7.6 ph and do not at this moment have a KH/GH testing kit (It'll be coming this weekend).
Gavin Citrus is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 08-13-2014, 07:50 PM
Planted Tank Guru
 
klibs's Avatar
 
PTrader: (29/100%)
Join Date: May 2014
Location: NH
Posts: 3,325
What ferts / how much you need greatly depends on what lighting / carbon source you have.

What lights do you have / are you injecting CO2? Using Excel? DIY CO2?


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
klibs is offline  
post #3 of 3 (permalink) Old 08-13-2014, 10:45 PM Thread Starter
Planted Tank Obsessed
 
Gavin Citrus's Avatar
 
PTrader: (0/0%)
Join Date: Aug 2014
Location: St. Louis, Missouri
Posts: 378
I have a Current USA model 1122 that I am running two of the four lights. Both are 54W Aquablue Special T5HO by ATI. I run them at just over 6 hours per day.

No CO2 currently in any fashion.
Gavin Citrus is offline  
Reply

Tags
None

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the The Planted Tank Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome