What else can I do? - The Planted Tank Forum
 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 03-30-2006, 03:12 PM Thread Starter
Planted Member
 
PTrader: (0/0%)
Join Date: Jul 2005
Location: Saint John, New Brunswick
Posts: 264
What else can I do?

Hi,

It's been a couple weeks now that I've been adding ferts to my tank, and although it has improved I am still seeing algea growth.
It's the green stuff that grows on the plants, GBA maybe??

Here's my current specs:

75gal
120-140Watts light (dont know for sure because I am OD 4 T8's)
10 hours of light.
Ph currently is 7.0-7.1? according to hagen test kit
Phosphate between 2.5 and 5 - hagen test kit, but definetly closer to 2.5 than 5.
Gh 220
kh 170 (all hagen test kit)
I am using pressurized co2 (otherwise my ph is around 7.8)
The only test kit I dont have is for nitrates so I dont know what it is right now, but I plan on getting one today.

Ferts I am dosing 3X week:
3/4 KNO3
3/16 (pinch) kh2po4
1/4 k2so4
and on alternate days dosing 60ml of nutrafin plant gro iron. (will switch to plantex as soon plant gro is done in a couple days)

As I said, it is much better that it was before I started dosing, but I am still seeing algae growth.
So what else can I do to eliminate growth?

Thanks for all the help.
HammerJoe is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 04-02-2006, 03:31 AM
Guest
 
PTrader: (0/0%)
Join Date: Apr 2005
Posts: 67
Cut back on your lights and see how that goes. Maybe only give them 8 hours or so a day. Other then that go no lights for a day or 2. I also fond that when I have setup a new tank it can take quite a few months for everything to stabilaze and this can contribute to alge I find.
jastormont is offline  
post #3 of 3 (permalink) Old 04-02-2006, 08:41 PM Thread Starter
Planted Member
 
PTrader: (0/0%)
Join Date: Jul 2005
Location: Saint John, New Brunswick
Posts: 264
I've had this tank for awhile now, I only started adding ferts a couple weeks ago.

Cutting on the lights, wont that affect plants as well?

Another question, I did my water change today and did my regualr fert dosage and tested for nitrates and it shows a result below 10ppm.

Is this where it should be or should I be targetting for 20ppm?
HammerJoe is offline  
Reply

Tags
None

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the The Planted Tank Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome