Signs of magnesium deficiency? - The Planted Tank Forum
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 33 (permalink) Old 09-27-2012, 03:09 AM Thread Starter
Planted Tank Guru
 
PTrader: (18/100%)
Join Date: Jan 2011
Location: TN
Posts: 2,045
Signs of magnesium deficiency?

What are the symptoms of Mg deficiency?

Snail Glades,
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
.
Rainer is offline  
Sponsored Links
Advertisement
 
post #2 of 33 (permalink) Old 09-27-2012, 08:19 PM
Planted Tank Guru
 
PTrader: (84/100%)
Join Date: Dec 2005
Location: Sacramento, CA
Posts: 21,012
If you suspect a magnesium deficiency you can easily test for it by adding around 5-10 ppm of magnesium to the water and watching the plants to see if they grow better and more healthy. That is far better than trying to determine the need for magnesium by looking at plants that aren't doing well.

Hoppy
Hoppy is offline  
post #3 of 33 (permalink) Old 09-27-2012, 10:22 PM Thread Starter
Planted Tank Guru
 
PTrader: (18/100%)
Join Date: Jan 2011
Location: TN
Posts: 2,045
I don't have any on hand and would rather avoid ordering any unless necessary. Here's my problem:

Click image for larger version

Name:	uploadfromtaptalk1348783326267.jpg
Views:	572
Size:	49.1 KB
ID:	54456

Note the color of the detached leaf (one of two today) in comparison to the top of the same plant below. Also note the detached Cyperus blade - vals die quickly in here and Cyperus is barely holding its own.

This is a modified EI-dosed tank:
KNO3 - 3x 1/4 tsp
KH2PO4 - 3x 1/16 tsp
K2SO4 - 3x 1/16 tsp
CSM+B - 3x 1/16 tsp
DC - light green, maxed out

I also use root tabs and eco-complete, which should be fully charged. I don't dose GH Booster since tap is 8-9 dGH; theoretically a magnesium deficiency is a possibility.

Snail Glades,
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
.
Rainer is offline  
 
post #4 of 33 (permalink) Old 09-27-2012, 10:57 PM
Planted Tank Guru
 
happi's Avatar
 
PTrader: (21/100%)
Join Date: Dec 2009
Location: Salt Lake City, UT
Posts: 3,139
Send a message via Yahoo to happi
Quote:
Originally Posted by Rainer View Post
I don't have any on hand and would rather avoid ordering any unless necessary. Here's my problem:

Attachment 54456

Note the color of the detached leaf (one of two today) in comparison to the top of the same plant below. Also note the detached Cyperus blade - vals die quickly in here and Cyperus is barely holding its own.

This is a modified EI-dosed tank:
KNO3 - 3x 1/4 tsp
KH2PO4 - 3x 1/16 tsp
K2SO4 - 3x 1/16 tsp
CSM+B - 3x 1/16 tsp
DC - light green, maxed out

I also use root tabs and eco-complete, which should be fully charged. I don't dose GH Booster since tap is 8-9 dGH; theoretically a magnesium deficiency is a possibility.
looking at that plant it rather looks like Fe deficiency. Mg deficiency looks similar but it start from the bottom of the plant and goes up, bottom leaves of that plant are green, so no Mg deficiency in your case.

try increasing the Fe

DIY Trace/Micro/Macro Recipe
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


DIY Trace/Micro/Calculation Etc
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
happi is offline  
post #5 of 33 (permalink) Old 09-27-2012, 11:37 PM Thread Starter
Planted Tank Guru
 
PTrader: (18/100%)
Join Date: Jan 2011
Location: TN
Posts: 2,045
That's a transplanted hygro that had beautiful leaves mottled red and green when acquired. The lower leaves have darkened and are falling off like the one floating in the corner. One still attached can be seen on the right side.

The new growth seen in the center is a lighter green.

Snail Glades,
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
.
Rainer is offline  
post #6 of 33 (permalink) Old 09-28-2012, 01:54 AM
Planted Tank Enthusiast
 
lipadj46's Avatar
 
PTrader: (5/100%)
Join Date: Apr 2011
Location: NY
Posts: 939
Quote:
Originally Posted by Rainer View Post
I don't have any on hand and would rather avoid ordering any unless necessary.
You do not need to order MgSO4 just go buy some epsom salts for a couple bucks from the local drug store/grocery store.
lipadj46 is offline  
post #7 of 33 (permalink) Old 09-28-2012, 04:36 AM
Planted Tank Guru
 
PTrader: (0/0%)
Join Date: Jan 2010
Location: Contra Costa CA
Posts: 11,721
High GH out of the tap is usually suggestive that there are both Ca and Mg, but not always!
Easiest thing to do: Add some Epsom salt to the tank, see if the plants improve.
Diana is offline  
post #8 of 33 (permalink) Old 09-28-2012, 01:04 PM Thread Starter
Planted Tank Guru
 
PTrader: (18/100%)
Join Date: Jan 2011
Location: TN
Posts: 2,045
I'm picking up some today and assuming it should be dosed weekly, like GH Booster, at the dose Hoppy suggested.

Thanks!

Snail Glades,
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
.
Rainer is offline  
post #9 of 33 (permalink) Old 09-28-2012, 04:44 PM
Planted Tank Guru
 
PTrader: (84/100%)
Join Date: Dec 2005
Location: Sacramento, CA
Posts: 21,012
Quote:
Originally Posted by Rainer View Post
I'm picking up some today and assuming it should be dosed weekly, like GH Booster, at the dose Hoppy suggested.

Thanks!
The last word I read on dosing magnesium is to dose 3 times as much as you are dosing CSM+B - if you dose 1/4 tsp of CSM+B, dose 3/4 tsp of magnesium sulfate. If you dose the CSM+B 3X per week, also dose the MgSO4 at the same time.

I jotted this on a scratch pad when I read it - I think it was from Plantbrain.

Hoppy
Hoppy is offline  
post #10 of 33 (permalink) Old 09-28-2012, 05:29 PM
ShrimpRetirement
 
speedie408's Avatar
 
PTrader: (397/100%)
Join Date: Jan 2009
Location: Central Cali
Posts: 8,313
Loss of leaves was my issue when I had a Mg deficiency. My crypts would just start losing leaves one by one.

Mg works a bit like magic. You can start seeing improvement in the affected plants almost overnight.

Hoppy's dosing notes sound correct.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
|
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
|
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
|
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
|
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
speedie408 is offline  
post #11 of 33 (permalink) Old 09-28-2012, 09:00 PM Thread Starter
Planted Tank Guru
 
PTrader: (18/100%)
Join Date: Jan 2011
Location: TN
Posts: 2,045
We'll see how it goes but I think we're on the right track. Thanks for all the assistance especially on the dosing.

Snail Glades,
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
.
Rainer is offline  
post #12 of 33 (permalink) Old 10-01-2012, 03:45 AM Thread Starter
Planted Tank Guru
 
PTrader: (18/100%)
Join Date: Jan 2011
Location: TN
Posts: 2,045
Lost several more hygro leaves during WC today, mostly from mid-level. One in particular was both curved downward and strongly cupped and the edges were discolored.

Tomorrow is Day 2 of Mg dosing.

Snail Glades,
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
.
Rainer is offline  
post #13 of 33 (permalink) Old 10-03-2012, 12:21 AM
Planted Tank Guru
 
happi's Avatar
 
PTrader: (21/100%)
Join Date: Dec 2009
Location: Salt Lake City, UT
Posts: 3,139
Send a message via Yahoo to happi
how is it going man?

DIY Trace/Micro/Macro Recipe
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


DIY Trace/Micro/Calculation Etc
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
happi is offline  
post #14 of 33 (permalink) Old 10-03-2012, 02:07 AM Thread Starter
Planted Tank Guru
 
PTrader: (18/100%)
Join Date: Jan 2011
Location: TN
Posts: 2,045
Found another detached hygro leaf, though it could have trapped during the WC on Sunday. Tomorrow is the third dose.

Snail Glades,
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
.
Rainer is offline  
post #15 of 33 (permalink) Old 10-03-2012, 01:40 PM
Planted Tank Guru
 
PTrader: (0/0%)
Join Date: Jan 2010
Location: Contra Costa CA
Posts: 11,721
What is the GH doing when you dose?

If it is just going up, then the plants are not using much of the added Mg. Problem may be something else.

If it goes up when you dose, then drops a bit over the next few days then the plants are using some of it. You are on the right track with adding Mg.
Diana is offline  
Reply

Tags
None

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the The Planted Tank Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome