New tank questions - The Planted Tank Forum
 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 07-24-2012, 12:16 PM Thread Starter
Algae Grower
 
slidewithme's Avatar
 
PTrader: (4/100%)
Join Date: May 2012
Location: Antioch, CA
Posts: 72
Unhappy New tank questions

I setup my first planted tank (40g) about 5 weeks ago, and I'm having some issues.

I've gotten most of my plants from fabulous people here on TPT, so they've come from a lot of different tanks. I'm not sure if that matters, here.

Issue 1: My tank is still not cycled after 5 weeks of using the fish food method; I've even used SeaChem's Stability, which was recommended by a lot of people here (and on Reddit, and in my LFS) to speed up the process. I tested yesterday (API liquid tests) and ammonia was about 2ppm, nitrites and nitrates were at 0ppm. I'm starting to think the things I used to treat the water when I set up the tank are to blame; I noticed after the fact that one of them "removes nitrites and nitrates" (NovAqua+). Could that be preventing the tank from cycling properly?

Issue 2: I've got rust-like algae on the leaves of some of my plants, which from browsing the algae forum I've learned is fairly common for a new tank. Should I do something to get rid of it? If so, how do I treat it? The tank has a single fish (neon tetra), who has lived through all this cycling mess, so I don't want to kill him now by trying to treat algae.

Honestly, I have no idea how he's still alive. I feel terrible that of the 5 fish I added when I started using Stability, 4 of them died. The one left is obviously immortal, so I named him Zeus.

Of all the other tanks I've cycled/kept, I've never had it take this long just to START the process. I mean, I don't even have any nitrites yet. Granted, this is the largest tank I've ever had, but... man. :/

Suggestions/comments?

Come join us in
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
on Reddit!
slidewithme is offline  
Reply

Tags
None

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the The Planted Tank Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome