Newbie fertilizer question - The Planted Tank Forum
 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 12-09-2011, 12:18 PM Thread Starter
Algae Grower
 
Jacca5's Avatar
 
PTrader: (3/100%)
Join Date: Oct 2011
Location: Hodgenville ky
Posts: 62
Newbie fertilizer question

Is this a good fert for a planted tank it contains
2% nitrogen
p2o2 15%
k2o 15%

It is Monty's 2-15-15 liquid plant food. I have been using it and Flourish fertilizer.
Jacca5 is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 12-09-2011, 01:43 PM
Planted Tank Guru
 
PTrader: (33/100%)
Join Date: Jul 2011
Location: Gone
Posts: 5,994
It's strainer than I would use.

I use Atlantis Fist Fertilizer (Fish emulsion) 4-2-0
And Aqueon Plabnt food 0-0-1 + Micros

I keep shrimp in my tanks so I know it;s safe, But, to be sure I have emailed Bodine the maker of Atlantis...NO COPPER.
DogFish is offline  
post #3 of 3 (permalink) Old 12-09-2011, 05:16 PM
Planted Tank Guru
 
PTrader: (84/100%)
Join Date: Dec 2005
Location: Sacramento, CA
Posts: 21,012
That isn't a good aquatic plant food. Aquatic plants need N and K in about 4X the amounts of P. And, most terrestrial plant foods contain urea as a source of nitrogen, which isn't a good choice for aquarium use.

Hoppy
Hoppy is offline  
Reply

Tags
None

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the The Planted Tank Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome