Help me correct this deficiency - The Planted Tank Forum
 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 11-25-2011, 04:36 AM Thread Starter
Algae Grower
 
PTrader: (4/100%)
Join Date: Feb 2010
Location: maplewood
Posts: 37
Help me correct this deficiency

29 gallon standard
1x65 watt Coralife PC
Aquatop CF-300

DKH is at yellow green
I am dosing EI
1/4 tsp KNO3
1/16 tsp KH2PO4
1/16 tsp Trace
all three times a week.

Looking at a deficiency diagram I believe I am at a phosphate deficiency because my plants develop pinholes then they melt away. Usually on older leaves, some just have pinholes and show nothing else.
I have tried upping Phosphate to as much as 1/4 x3 a week and I am still getting the same results. IDK if I might have a Potassium deficiency, but reading some articles, they indicate I may not need any K dosing because the first 2 macro nutrients have enough.

My tank is not heavily planted I don't understand what they are utilizing so much that I am missing.
I do have a lot of pond snails in my tank and no fish, could it be that the snails are salvaging my plants?
My Ludwigia sp. Leaves are not as big or open as they were when I got them also.

I have attached some pictures of the problem
Java Fern

S. Repens

R. ranalisma?

FTS

Sorry for dirty tank picture.
jocky is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 11-25-2011, 05:15 AM
Planted Tank Guru
 
PTrader: (84/100%)
Join Date: Dec 2005
Location: Sacramento, CA
Posts: 21,012
By far the most common deficiency is CO2. If you are using pressurized CO2 you can try increasing the bubble rate quite a bit, since you have no fish to worry about. If you have DIY CO2, try using another bottle, to get more CO2.

The 65 watt PC lights most commonly sold in LFS seem to all have very poor reflectors, so you may have only low light, possibly very low light. If so, it might be the light which is limiting the plants growth.

Hoppy
Hoppy is offline  
post #3 of 4 (permalink) Old 11-26-2011, 01:26 AM Thread Starter
Algae Grower
 
PTrader: (4/100%)
Join Date: Feb 2010
Location: maplewood
Posts: 37
I do have a pressurized system, I'll try to up that more.

But looking at the pictures, do you think I have any other deficiency?
jocky is offline  
 
post #4 of 4 (permalink) Old 11-26-2011, 01:31 AM
Planted Tank Guru
 
PTrader: (84/100%)
Join Date: Dec 2005
Location: Sacramento, CA
Posts: 21,012
Instead of going by the pictures, which I can't do, I can say that you don't seem to be dosing any GH booster, so you may have a shortage of calcium, or more likely, of magnesium.

Hoppy
Hoppy is offline  
Reply

Tags
None

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the The Planted Tank Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome