Tank water smells somewhat fishy? - The Planted Tank Forum
 
LinkBack Thread Tools Display Modes
post #1 of 11 (permalink) Old 11-14-2011, 06:08 PM Thread Starter
Planted Tank Guru
 
PTrader: (23/100%)
Join Date: Apr 2011
Location: Durham, NC
Posts: 2,261
Tank water smells somewhat fishy?

Topic. I can't think of anything that would be causing it though...No dead/rotting critters since I check weekly for them unless they're doing a splendid job of hiding. I also run a Koralia Nano 240 for surface agitation 24/7 as well as inject CO2. I have a 20g tall that's neglected (haven't done a WC in a month and a half) and it has virtually no smell. Same filter, no Koralia. ~25 small fish, tons of MTS, a rubberlip pleco, ~10 ghost shrimp. Relevant tank specs and stocking:

20g long tank
HC carpet, still growing in
Patch of fissidens fontanus
Granite rocks
Aquasoil Amazonia NEW, 9L
Power Sand Special-S, 2L
EI dosing, KNO3 replaced with K2SO4 due to nitrates in tap + AS + fish
Eheim 2215 with 200mL of Purigen, cleaned about a month ago

Stocking:
5 Otocinclus vittatus
9 Corydoras pygmaeus
20 (I think) Espei rasboras
3 Fire Red Cherry Shrimp
3-4 Amano Shrimp



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
freph is offline  
Sponsored Links
Advertisement
 
post #2 of 11 (permalink) Old 11-14-2011, 06:20 PM
Planted Tank Obsessed
 
PTrader: (0/0%)
Join Date: May 2011
Location: California
Posts: 430
Have you checked Ammonia/Nitrite/Nitrate levels? Smell is a good sign that something funky is going on with the water chemistry. Also check for a BGA outbreak which also can smell funky.
RandomMan is offline  
post #3 of 11 (permalink) Old 11-14-2011, 06:22 PM
Planted Tank Guru
 
HD Blazingwolf's Avatar
 
PTrader: (8/100%)
Join Date: May 2011
Location: Chattanooga, TN
Posts: 4,907
i find that water can just be changed and without a semi clean filter.. boom smell.. or there could be a buildup of uneaten food protein in the substrate.

my suggestion would be to make a mess.. stir the substrate a lot. take a new and capture bigger particles that come up. siphon 50% of the water
when things settle. clean the filer
wait one day and check smell

edit: just realized u just cleaned filter.

aquasoil releases ammonia. reduce nitrate dosing and let ur plants absorb some. put in a ammonia pillow? or pickup some nutrafin cycle. it will help convert the ammonia.
that bacteria in it is ready to go after ur pour it in

Sump Pimp #7

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
HD Blazingwolf is offline  
 
post #4 of 11 (permalink) Old 11-14-2011, 06:27 PM Thread Starter
Planted Tank Guru
 
PTrader: (23/100%)
Join Date: Apr 2011
Location: Durham, NC
Posts: 2,261
Tank has been setup since 8/23. I cleaned the filter in just tank water to make sure I didn't kill any bacteria and the only thing I thoroughly cleaned was the coarse foam and replaced the fine pad. No BGA, only a very small amount of BBA here and there. 0 Ammonia, 0 Nitrite, Nitrates 50~170 depending on what day it is. It's usually in the 170 range before I do a WC...HC isn't in full boom yet so my nitrate consumption is a bit low. Also, I do 2x 50% WC a week.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
freph is offline  
post #5 of 11 (permalink) Old 11-15-2011, 01:17 AM Thread Starter
Planted Tank Guru
 
PTrader: (23/100%)
Join Date: Apr 2011
Location: Durham, NC
Posts: 2,261
Bump.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
freph is offline  
post #6 of 11 (permalink) Old 11-17-2011, 07:49 PM
Planted Member
 
PTrader: (1/100%)
Join Date: Oct 2011
Location: Solon, IA
Posts: 177
strange !
Byakuya is offline  
post #7 of 11 (permalink) Old 11-18-2011, 02:25 PM
Planted Tank Guru
 
HD Blazingwolf's Avatar
 
PTrader: (8/100%)
Join Date: May 2011
Location: Chattanooga, TN
Posts: 4,907
still have a fishy smell?

Sump Pimp #7

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
HD Blazingwolf is offline  
post #8 of 11 (permalink) Old 11-18-2011, 05:40 PM Thread Starter
Planted Tank Guru
 
PTrader: (23/100%)
Join Date: Apr 2011
Location: Durham, NC
Posts: 2,261
It's actually pretty minimal right now for whatever reason. Various things could have caused that. I switched foods (Ken's community flake and catfish sticks, still using inverteBites green), haven't (nor am I going to) done a WC today, got 16(17?) shrimp in yesterday, trimmed the HC not too long ago, moved my Koralia up about a half inch and got my CO2 tank refilled. Who knows.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
freph is offline  
post #9 of 11 (permalink) Old 11-18-2011, 06:12 PM
Planted Tank Enthusiast
 
tonytrout2001@hotmail.com's Avatar
 
PTrader: (14/100%)
Join Date: Apr 2011
Location: Cosby, Tn.
Posts: 804
Send a message via MSN to tonytrout2001@hotmail.com Send a message via Yahoo to tonytrout2001@hotmail.com
I find it helps with the smell when I top my tank off with some tap water. You can get it pretty close to temperature from the faucet and add that. It should be alright for the shrimps, as long as you're not filling the tank or doing like a 50% wc with it.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
#15

Just because its dirt doesn't make it low tech.
Updated 9-7
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
President.
post #10 of 11 (permalink) Old 11-18-2011, 06:36 PM Thread Starter
Planted Tank Guru
 
PTrader: (23/100%)
Join Date: Apr 2011
Location: Durham, NC
Posts: 2,261
My tap is pretty good for shrimp. Soft, ~6.4pH well water and the only thing is has in it is ~40ppm nitrates. It still tastes quite delicious though.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
freph is offline  
post #11 of 11 (permalink) Old 11-18-2011, 09:28 PM
Planted Tank Guru
 
HD Blazingwolf's Avatar
 
PTrader: (8/100%)
Join Date: May 2011
Location: Chattanooga, TN
Posts: 4,907
well water is the best

Sump Pimp #7

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
HD Blazingwolf is offline  
Reply

Tags
None

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the The Planted Tank Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome