White surface scum on top of tank - The Planted Tank Forum
 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 11-13-2011, 05:50 PM Thread Starter
Planted Member
 
PTrader: (1/100%)
Join Date: May 2010
Location: CA
Posts: 184
White surface scum on top of tank

ever since i started dosing EI i have had this very hazy/white surface layer on the top of my tank. I have tons of surface agitation from my HOB filter that runs 24/7 so i dont think this goes away with surface agitation.

I am doing macros and micros + 1.5ml iron every other day

I have a 15 gallon tank

I read online that the white surface scum could be caused by lots of iron, but it was only from one source and cant really find much about the cause anywhere else.

Can anyone provide any insight on this problem? thanks!
kilfrg7864 is offline  
Reply

Tags
None

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the The Planted Tank Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome