vals americana not straight, nutrient deficiency? - The Planted Tank Forum
 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 07-05-2011, 02:02 AM Thread Starter
Algae Grower
 
PTrader: (2/100%)
Join Date: Aug 2006
Location: Jersey City, NJ
Posts: 145
vals americana not straight, nutrient deficiency?

Hi, my twisted vals are kinda droopy(?), the leaves are not straight point up but falling on the side like flower pedal. Does anyone know what kind of nutrient deficiencies those are?


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
gagaliya is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 07-05-2011, 07:06 PM
Wannabe Guru
 
PTrader: (12/100%)
Join Date: Nov 2010
Location: White Plains, MD
Posts: 1,001
With my limited experience, sounds like not enough CO2 possibly. Although Vals are pretty easy to grow anywhere. Would help to know more about your tank. I recently had a CO2 issue that had been going on for close to a month before I figured out what was going on. I put some Rotala Indica in my tank and the stems never straightened out from the way they droop a little when you first put them in there. Fixed my CO2 issue and within a few days those stems were as straight as a nail. The CO2 issue didn't affect the other plants I had in my tank, but I did get a bad bout of BBA.

Eheim Pimp #448
jrman83 is offline  
post #3 of 3 (permalink) Old 07-05-2011, 10:37 PM Thread Starter
Algae Grower
 
PTrader: (2/100%)
Join Date: Aug 2006
Location: Jersey City, NJ
Posts: 145
Quote:
Originally Posted by jrman83 View Post
With my limited experience, sounds like not enough CO2 possibly. Although Vals are pretty easy to grow anywhere. Would help to know more about your tank. I recently had a CO2 issue that had been going on for close to a month before I figured out what was going on. I put some Rotala Indica in my tank and the stems never straightened out from the way they droop a little when you first put them in there. Fixed my CO2 issue and within a few days those stems were as straight as a nail. The CO2 issue didn't affect the other plants I had in my tank, but I did get a bad bout of BBA.
cant be co2, i have a pressurized co2 at 2 bubble/sec in a 15 gallon biocube. The dropchecker is almost yellowish. I remember reading a while back this could be one of the macro deficiencies, but cant find the thread anymore.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
gagaliya is offline  
Reply

Tags
None

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the The Planted Tank Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome