Help Identifying deficiency. - The Planted Tank Forum
 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 05-08-2011, 01:08 AM Thread Starter
Algae Grower
 
PTrader: (0/0%)
Join Date: Feb 2011
Location: Nova Scotia Canada
Posts: 57
Help Identifying deficiency.

I am at a loss of what I need dose or add in order to get greener growth. My Vals and Swords are showing pale/yellow new growth.

I have a 30 gallon that has been cycled for about two months. I have 60 watts of t8 lighting (1x 30 watt life-glo 6500k and 1x 30 watt Power-GLo) I have been using DIY CO2 for a few weeks and get around 10-30 ppm acording to the KH/PH chart. I added a dose of Nutrafin Plantgro 4 days ago and the new Val growth is still yellow.

My first thoughts are Iron deficiency but I would like the thoughts of the people on here. I do not want to get into dosing EI as the plan was to keep it low tech.

LEVELS

PH - 7-7.2
NO2 - 0 ppm
NO3 - 5-20 ppm
NH3 - 0 ppm
KH - 5-6
PO4 - .5-1 ppm
Attached Thumbnails
Click image for larger version

Name:	IMG_0880.jpg
Views:	50
Size:	239.2 KB
ID:	30726  

Click image for larger version

Name:	IMG_0882.jpg
Views:	46
Size:	111.9 KB
ID:	30727  

sreid is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 05-08-2011, 02:35 PM
Planted Tank Guru
 
Kathyy's Avatar
 
PTrader: (35/100%)
Join Date: Feb 2010
Location: Newbury Park, CA
Posts: 4,203
New growth is often pale. My big Anubias' new leaves really look odd then they green up nicely. Think how java fern fronds are actually transparent when they open up.
Kathyy is offline  
post #3 of 4 (permalink) Old 05-08-2011, 07:18 PM
Planted Tank Enthusiast
 
Aquaticz's Avatar
 
PTrader: (3/100%)
Join Date: Dec 2009
Location: Los Angeles, CA
Posts: 848
How about some root tabs every six months

Regards,
Aquaticz
Aquaticz is offline  
 
post #4 of 4 (permalink) Old 05-08-2011, 09:30 PM
Planted Tank Guru
 
Sharkfood's Avatar
 
PTrader: (2/100%)
Join Date: May 2010
Location: Pittsburgh, Pa
Posts: 2,536
I used to have yellow leaves before I started EI dosing. In my case it was low nitrates. This is something I commonly see in low tech or undosed tanks. Lighting levels that are too low can pale growth also.

I see you report that you have 5ppm nitrate at the very minimum, which should be fine as long as your test is accurate.

In any case, starting to add a little iron isn't going to hurt anything.
Sharkfood is offline  
Reply

Tags
None

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the The Planted Tank Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome