Nutrient deficiency? - The Planted Tank Forum
 
LinkBack Thread Tools
Old 02-09-2020, 10:27 PM Thread Starter
Planted Member
 
butchblack's Avatar
 
PTrader: (0/0%)
Join Date: Oct 2019
Location: Waltham, Massachusetts, USA
Posts: 192
Nutrient deficiency?

I got my 75G fully planted about a month ago. I'm noticing this on my amazon swords, but just a few. Is this a nutrient deficiency, overcrowding? The tank was lightly populated until yesterday (7 Cory cats).





The tank has medium-high light, CO2, and I've been dosing with easy green and easy iron usually 4-5 X a week. PH around 6.6 dKH between 2-4. Any suggestions welcome.

The real fountain of youth is being a musician
butchblack is offline  
Sponsored Links
Advertisement
 
Old 02-09-2020, 10:46 PM
Algae Grower
 
athyra_firestorm's Avatar
 
PTrader: (0/0%)
Join Date: Jan 2020
Posts: 21
Following this because I am having the exact same issue with my Amazon sword plant. Mine has been in the tank for a month, also. I am thinking nitrogen deficiency since my nitrates are low and my other plants are showing very pale new growth, but not 100% sure.

Sent from my moto z4 using Tapatalk
athyra_firestorm is offline  
 

Tags
None

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the The Planted Tank Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Thread Tools



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome