Balancing ferts and light. Help! - The Planted Tank Forum
 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 09-05-2019, 04:57 PM Thread Starter
Planted Tank Enthusiast
 
aquanerd13's Avatar
 
PTrader: (0/0%)
Join Date: Jun 2019
Location: Your imagination.
Posts: 740
Exclamation Balancing ferts and light. Help!

I am starting to see slimy green stringy algae on a piece of driftwood in my tank. I also have a little bit of brown algae on the glass. I have the light on for 5 hours a day and have been dosing seachem flourish twice a week. Yesterday I added 13 DIY root tabs filled half with osmocote plus and half with sand so they sink. I have no supplemental co2 and it is not stocked yet. I am still cycling.

75 gallon low tech low light no supplemental co2 planted community freshwater tropical tank(Quite the mouthfull!!) Cycling now.
10 gallon species tank with 11 neon tetras

"Do not pray for an easy life. Pray for the strength to endure a difficult one” – Bruce Lee

See my 75 gallon tank journal!
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
aquanerd13 is offline  
Reply

Tags
None

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the The Planted Tank Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome