new 10g set up - The Planted Tank Forum
 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 08-16-2019, 01:58 PM Thread Starter
Algae Grower
 
PTrader: (0/0%)
Join Date: Aug 2019
Location: Michigan
Posts: 30
new 10g set up

Hi! I have had a 75gallon lo tech planted tank in the past, did well, but I moved and have downsized. I am now setting up an Innovative Marine Nuvo 10 gallon with a Kessil light. I am thinking of plants, maybe shrimp, tetras, dwarf cory or just a pea puffer. I have ordered Controlsoil substrate. My tap water is over 8 Ph and likely high GH (will test today when kit comes in). I am thinking of using all RO water or at least mixing to get better Ph and GH; I have always had algae issues in the past so hoping to minimize that plus minimize fighting Ph all the time. I recall that if I remineralize the RO water, set the KH and GH to 3 to 4 ppm and let the Ph be what it will I should be ok, right???

Also, I am thinking of trying CO2 this time around and debating between the Fluval (just to get my feet wet) and the C02 Advanced Forest (I don't want to do DIY).

So, question, should I get my water parameters balanced and cycle first then add CO2 or do it all at once? Any other comments or help!! Thank you!
fish+plants is online now  
Reply

Tags
None

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the The Planted Tank Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome