Algae + nutrient deficiency help! - The Planted Tank Forum
 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 08-12-2019, 12:20 AM Thread Starter
Algae Grower
 
PTrader: (0/0%)
Join Date: Aug 2019
Location: Maryland
Posts: 133
Algae + nutrient deficiency help!

I'm trying to trouble shoot a nutrient deficiency right now. Symptoms effecting old leaves so I'm figuring it's either N, P or K. My aquarium is heavily stocked. And I've heard that a heavily stocked aquarium might not need to dose NO3 or PO4. I know that all depends on how many plants I have though. I just want to know if I can trust my phosphate test. Someone told me nitrates can hide out in the substrate and a standard water column test wont show them obviously. If this is true for phosphate it adds another layer of difficulty trouble shooting.

Right now I have Flourish Potassium, Flourish Comprehensive, Flourish Iron, and Flourish, Nitrogen. My nitrate test shows it's barely above 0 or basically I know it's not 0 but it's definitely not much higher.

I just started to get GDA slowly growing on my walls. I cleaned the walls did a water change and took light duration down by half. Algae did not increase in 4 days. With the plants being nutrient deficient I'd rather bring the light and co2 back up. But unless I can get this nutrient deficiency problem figured out all that light and co2 might as well go towards more algae.
nothreat33 is offline  
Reply

Tags
None

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the The Planted Tank Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome