CSM+B micros causes staghorn algae - The Planted Tank Forum
 1Likes
  • 1 Post By cl3537
 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 03-22-2019, 10:11 PM Thread Starter
Planted Member
 
PTrader: (0/0%)
Join Date: Jan 2019
Posts: 274
CSM+B micros causes staghorn algae

Everytime I dose csm+b, both normal and small amounts, I have staghorn algae on my plants the next day. It never fails.

I've tested this about three times over the last month.

Is this normal? I'm trying to get my plants their micros but this is causing an issue.
Ddrizzle is online now  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 03-22-2019, 11:24 PM
Planted Tank Enthusiast
 
cl3537's Avatar
 
PTrader: (0/0%)
Join Date: Jan 2019
Location: Montreal, Quebec
Posts: 534
No correlation has ever been proven like that. But I would be looking at your light, co2 levels, and Macros first. If you have low/unhealthy plant mass its easy to get algae for a variety of reasons, the least likely of them is micros.

When I switched to EI I got a lot of hair algae, its gone now, but it would have been a false conclusion (it was related to lighting) to say it was because of the increased fertilizers.
Greggz likes this.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
cl3537 is offline  
post #3 of 3 (permalink) Old 03-22-2019, 11:31 PM Thread Starter
Planted Member
 
PTrader: (0/0%)
Join Date: Jan 2019
Posts: 274
Everything else is normal, that's why this was easy to test. Drop in csm+b, look at staghorn algae the next day.

30ppm co2, 20ppm nitrate, 1ppm phosphate. I'm not sure what my calcium and magnesium ratio is, but my gh is around 7. Iron might be high but I'll need to check again this weekend.
Ddrizzle is online now  
Reply

Tags
None

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the The Planted Tank Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Just read this on a site about algae Subtletanks91 Algae 16 04-20-2014 05:12 PM
Long Green Algae in Low Light/ Faline10 Algae 5 12-01-2013 12:17 AM
How do plants suppress algae growth souffle General Planted Tank Discussion 43 01-19-2012 06:59 AM
Staghorn algae invasion! sweet chariot Algae 13 05-21-2011 02:00 AM
How do I get rid of detrius and staghorn algae?!?! CAM6467 General Planted Tank Discussion 3 06-05-2009 06:17 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome