Deficiency after starting EI with dry ferts - The Planted Tank Forum
 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 10-15-2018, 01:12 PM Thread Starter
Algae Grower
 
kilnakorr's Avatar
 
PTrader: (0/0%)
Join Date: Jul 2016
Location: Copenhagen, Denmark
Posts: 30
Deficiency after starting EI with dry ferts

Hi

After some small issues with commercial liquid fertilizers I starting using dry fertilizer (mixed with water).
Now my tests shows the various levels are much better, and I can actually get some nice readings using drop tests.

Some of my plants don't really agree. Especially my Rotala Macrandra, is looking a bit off, with green colors, looking like the red has 'chipped off'.



I have dimmed the lights just a bit also, due to a little GSA (probably, the lack of phosphate I was experiencing before starting with dry fertilizer).

Can anyone tell me what, could be the cause for my macrandra loosing it's red colors and generally looking a bit unhealthy?
Attached Thumbnails
Click image for larger version

Name:	20181015_145955.jpg
Views:	26
Size:	186.7 KB
ID:	870625  

kilnakorr is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 10-15-2018, 02:29 PM
Wannabe Guru
 
Quagulator's Avatar
 
PTrader: (0/0%)
Join Date: May 2015
Location: Forest City ON, Canada
Posts: 1,908
What, how much and how often are you dosing?
What is your pH / kH / gH ?

__________________________________

If it were easy we wouldn't be here

My 30g Journal:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Quagulator is offline  
post #3 of 3 (permalink) Old 10-15-2018, 03:11 PM
Planted Tank Guru
 
Maryland Guppy's Avatar
 
PTrader: (13/100%)
Join Date: Dec 2014
Location: Arnold
Posts: 3,277
Less light will make it green.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Growing is not that difficult.
Maryland Guppy is offline  
Reply

Tags
None

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the The Planted Tank Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Starting Dry Ferts JasonG75 Fertilizers and Water Parameters 3 09-23-2011 05:03 PM
Liquid ferts vs Dry ferts Hilde Fertilizers and Water Parameters 11 09-26-2009 03:02 AM
Gram scales for dry ferts PRSRocker3390 Equipment 14 09-10-2009 02:39 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome