Cycling tank having high nitrates - The Planted Tank Forum
 1Likes
  • 2 Post By natemcnutty
 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 10-18-2017, 09:10 PM Thread Starter
Algae Grower
 
PTrader: (0/0%)
Join Date: Jun 2017
Posts: 53
Cycling tank having high nitrates

Hi guys, I was going through the first week of my fishless cycle in a planted ada 60p tank, with ada amazonia, powersand, and have been testing the water levels ,

day 5 of the test i am showing around .50ppm of ammonia , .50 or .25 ppm of nitrites and 40 or 80ppm cant make out of nitrates, is this normal?

do i need to go in and remove all the decaying plant matter?

i am dosing e.i and have been using seachem stability.
sudeep is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 10-22-2017, 06:37 AM
Planted Tank Guru
 
natemcnutty's Avatar
 
PTrader: (8/100%)
Join Date: May 2016
Location: Portland, OR
Posts: 2,394
Pretty sure that's normal. Amazonia has a good amount of ammonia in it, and you are dosing nitrates which is probably part of why it is so high. I believe most people just follow the ADA instructions for water changes and such. Removing decaying plant matter is always a good idea to about algae issues.

Sent from my Nexus 6 using Tapatalk
sudeep and sudeep like this.
natemcnutty is online now  
Reply

Tags
None

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the The Planted Tank Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome