Magnum 350 suck!!!!!
Planted Tank Forums
Your Tanks Image Hosting *Tank Tracker * Plant Profiles Fish Profiles Planted Tank Guide Photo Gallery Articles

Go Back   The Planted Tank Forum > Specific Aspects of a Planted Tank > Equipment


Reply
 
Thread Tools Display Modes
Old 06-27-2009, 07:01 AM   #1
three105
Planted Tank Obsessed
 
PTrader: (0/0%)
Join Date: Nov 2007
Location: Portland, OR
Posts: 458
Default

Magnum 350 suck!!!!!


I installed new impeller and it won't work now!!!!!!!!!!!!!!!!

Just makes horrid grinding noise.. Sounds like it is trying to go rarely on and off but won't i hate this filter, i hate it!!!!!!!!!!!!!!!!!!!!!!!!!!!!

What is wrong!?!?!? I bought new impeller put it into magnet.... Put it into bottom and put it in... Twice it's driving me nuts what is wrong!?!??!!

No there is no freakinngggg air in there wtf

i hate marineland!!!!!!!!! This canister is just a pita!!!!!!!!!!

Do i need a freaking new magnet too because marineland just sucks or what!?!?!??!?!?!


Help help help help help help help
three105 is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 06-27-2009, 07:03 AM   #2
Aquarist_Fist
Wannabe Guru
 
Aquarist_Fist's Avatar
 
PTrader: (6/100%)
Join Date: Jul 2008
Location: Portland, OR
Posts: 1,203
Default

Warranty exchange?
__________________
Pimp Club Member #313

Originally Posted by macclellan
my personal favorite is Random Capitalization. It is so Very fun and Surprising.
Aquarist_Fist is offline   Reply With Quote Quick reply to this message
Old 06-27-2009, 07:07 AM   #3
three105
Planted Tank Obsessed
 
PTrader: (0/0%)
Join Date: Nov 2007
Location: Portland, OR
Posts: 458
Default

what a piece... will a filstar xp2 be enough for a 72 planted bow, 4 angels eventually and a school of rummy nose... carpet growing HC, java fern on drift wood, dwarf hairgrass in a corner, 1 small bristlenose pleco
three105 is offline   Reply With Quote Quick reply to this message
Old 06-27-2009, 07:14 AM   #4
three105
Planted Tank Obsessed
 
PTrader: (0/0%)
Join Date: Nov 2007
Location: Portland, OR
Posts: 458
Default

It was already making a light grinding noise before I installed the new impeller and now it won't even work and just makes an even worse grinding noise... I'm f****ing sick of this filter... GOOD BYE MARINELAND YOU SUCK!!!!!!!!!!!!!!!! YOU SHOULDNT EVEN BE ALLOWED TO SELL THIS!!!!!!!!!!!!!!!
three105 is offline   Reply With Quote Quick reply to this message
Old 06-27-2009, 08:07 AM   #5
jinx©
Wannabe Guru
 
jinx©'s Avatar
 
PTrader: (6/100%)
Join Date: Oct 2007
Location: Sacramento, CA
Posts: 1,545
Default

The Magnum 350 isn't one of my favorite canister filters, but I've owned a couple in the past, and have also seen some that have ran a decade or more without any major problems.
If your impeller assembly and shaft are in good shape and spinning (or trying), it sounds like it's on working order but possibly assembled improperly. Double check that shafts ends are completely seated and inline as they should be.

An Xp would be a definite upgrade IMO, but I wouldn't consider anything less than an Xp3 or 4 for a 72g. I'd personally go with two Xp3's myself if you're intent on a Rena and planning any major planting.
__________________
jinx© is offline   Reply With Quote Quick reply to this message
Old 06-27-2009, 11:46 AM   #6
VisionQuest28
Planted Tank Enthusiast
 
VisionQuest28's Avatar
 
PTrader: (56/100%)
Join Date: Apr 2007
Location: Constantia, NY
Posts: 557
Default

I agree with jinx, while magnums can be a PITA at times, they are generally pretty reliable.
Problems i have had in the that kept them from working...not being put together properly, whether its the shaft or impellar or are you sure you have the base on the right way? I struggled with that a few times when i first started working with these. If the hole on the canister doesnt line up with the impellar it wont work. Another thing that has made them do what you describe is being clogged. What kind of shaped is the filter floss pad and/or micron pad and carbon container in??? If its so clogged that it cant draw water...then well, it cant draw water and wont work.

Just a few suggestions, hth. Sorry about your troubles...i definitely know how frustrating that crap can be!
VisionQuest28 is offline   Reply With Quote Quick reply to this message
Old 06-27-2009, 01:46 PM   #7
mountaindew
Planted Tank Obsessed
 
mountaindew's Avatar
 
PTrader: (0/0%)
Join Date: Dec 2008
Location: Colorado
Posts: 462
Default

Sounds like your impeller is not locked down on the magnet shaft. On all my filters it slides down about an 1/8" and locks in place, then I install impeller in canister housing, then the impeller housing and lift tube is carfully aligned and installed.
Now and then I forget to check this when assembling the filter and I get impeller rattle.
Want a bullet proof filter! buy a pentair a.f. series with 4000 hh pump. You can buy 6 magnum 350 filters for the cost of one of these units, but 20 years from now it will still be filtering your tank. Just figured I would recommend A commercial grade filter that never gets mentioned on these forums!
HTH md!
mountaindew is offline   Reply With Quote Quick reply to this message
Old 06-27-2009, 03:48 PM   #8
three105
Planted Tank Obsessed
 
PTrader: (0/0%)
Join Date: Nov 2007
Location: Portland, OR
Posts: 458
Default

going to fish shop in a bit... we'll see what happens
three105 is offline   Reply With Quote Quick reply to this message
Old 06-27-2009, 05:36 PM   #9
macclellan
H+
 
macclellan's Avatar
 
PTrader: (208/100%)
Join Date: Dec 2006
Location: Knoxkilla
Posts: 5,060
Default

Quote:
Originally Posted by jinx© View Post
An Xp would be a definite upgrade IMO, but I wouldn't consider anything less than an Xp3 or 4 for a 72g. I'd personally go with two Xp3's myself if you're intent on a Rena and planning any major planting.
I have run an XP1 and a Koralia 1 powerhead on my 75g for a year now. Heavily planted, co2, T5s, etc. No issues.

The trend on this forum is extremely excessive filtration (2x Rena XP3s on a 75g). Planted tanks don't need heavy filtration, but they do need high flow. Sure, a canister filter provides both, but a second canister filter is just a really expensive powerhead... just my opinion.
macclellan is offline   Reply With Quote Quick reply to this message
Old 06-27-2009, 07:40 PM   #10
Lnb
At 36,000'
 
Lnb's Avatar
 
PTrader: (19/100%)
Join Date: Apr 2008
Location: 10309 ~ NY
Posts: 1,079
Default

I've gotten to really dislike Marineland products. Their HOB's are better than the canisters. Not fond of their customer service either.

Rena Filstar is good, lots of power. Got 2 of those going and of course the Eheim Classics. Can't beat the Eheim's but you'll need a size larger than they recommend!! Trust me.

I feel your frustration ............ good-luck!
__________________

Eheim #293 ~ 2 x 2217 ~ 1 X 2215 *** Filstar #138 ~ XP 1 x 2
Lnb is offline   Reply With Quote Quick reply to this message
Old 06-27-2009, 11:52 PM   #11
CardBoardBoxProcessor
Planted Tank Enthusiast
 
PTrader: (5/100%)
Join Date: Sep 2006
Location: Annapolis, MD
Posts: 989
Default

teflon tape around the shaft and between the magnet will fix it for a bit. I did that with my xp4 wen it grinds it's shaft.
CardBoardBoxProcessor is offline   Reply With Quote Quick reply to this message
Old 06-28-2009, 01:27 AM   #12
CardBoardBoxProcessor
Planted Tank Enthusiast
 
PTrader: (5/100%)
Join Date: Sep 2006
Location: Annapolis, MD
Posts: 989
Default

if you want an XP2 I have the motor, all the pipes, most of the original tubing and baskets. the only thing it lacks is the bottom canister @_@ the clips broke on it. you can buy a new one for $40 - 50 and I can sell you everything I have for $40. That is still pretty cheap for an XP2.

can be bought

http://rena-aquatics-outlet.planetre...Parts-All.html
CardBoardBoxProcessor is offline   Reply With Quote Quick reply to this message
Old 06-28-2009, 04:50 PM   #13
three105
Planted Tank Obsessed
 
PTrader: (0/0%)
Join Date: Nov 2007
Location: Portland, OR
Posts: 458
Default

I ended up buying a magnet and it fixed it... it's still slightly grindy noisish... the inside where the impeller sits with the magnet is kinda scratched up as the magnet was... really pissing me off now... I might have to order a new canister part
three105 is offline   Reply With Quote Quick reply to this message
Old 06-28-2009, 04:53 PM   #14
three105
Planted Tank Obsessed
 
PTrader: (0/0%)
Join Date: Nov 2007
Location: Portland, OR
Posts: 458
Default

just ordered the canister part... total so far... I think $15 impeller... maybe $5 for impeller think it was 15... plus $40 magnet... +$26 canister
three105 is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the The Planted Tank Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 07:36 PM.


Powered by vBulletin®
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright Planted Tank LLC 2012