Trouble with new eheim 2126
Planted Tank Forums
Your Tanks Image Hosting *Tank Tracker * Plant Profiles Fish Profiles Planted Tank Guide Photo Gallery Articles

Go Back   The Planted Tank Forum > Specific Aspects of a Planted Tank > Equipment


Reply
 
Thread Tools Display Modes
Old 06-18-2004, 08:17 PM   #1
Shay
Planted Member
 
Shay's Avatar
 
PTrader: (7/100%)
Join Date: Apr 2004
Location: Pennsylvania
Posts: 198
Default

Trouble with new eheim 2126


Well, so far I'm not overly impressed with this equipment but hopefully things will get better. I finally got it all set up. The priming was cumbersome but eventually the filter filled up with water. I plugged it in and all I got was a clicking noise. I went to the manual and there are three reasons listed for this problem.

1) not plugged in
2) broken shaft
3) dirty/clogged impeller

It was definitly plugged in and I tried other outlets. Its unlikely to have a clogged or dirty impeller (although I'm going to check) that leaves only a broken shaft.

Luckily Dr.Fosters and Smith are fedexing a new one on monday for delivery Tuesday. If I only change out the canister I should have it up and running shortly.
__________________
Eheim Pimp Member # 38
Eheim 2126
55 gallon
4 X 65 coralife light
Pressurized CO2

Member of The Delaware Valley Aquatic Gardener's Association (www.dvaga.com), GWAPA and AGA.
Shay is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 06-18-2004, 09:20 PM   #2
Momotaro
Doesn't like Kool-Aid
 
Momotaro's Avatar
 
PTrader: (52/100%)
Join Date: Feb 2003
Location: Hawthorne, New Jersey
Posts: 10,125
Default

Is the shaft broken? You can disconnect the filter and check.

Priming my 2126 was an absolute breeze! I just pushed the plunger and the filter filled right up.

Mike
__________________
[SIGPIC][/SIGPIC]
Momotaro is offline   Reply With Quote
Old 06-18-2004, 11:59 PM   #3
Shay
Planted Member
 
Shay's Avatar
 
PTrader: (7/100%)
Join Date: Apr 2004
Location: Pennsylvania
Posts: 198
Default

Nope, the shaft is not broken but it is running. I took it apart and opened up the pump chamber and looked at the impeller. There was nothing there stuck in but when I put it back together it ran. Go figure!
__________________
Eheim Pimp Member # 38
Eheim 2126
55 gallon
4 X 65 coralife light
Pressurized CO2

Member of The Delaware Valley Aquatic Gardener's Association (www.dvaga.com), GWAPA and AGA.
Shay is offline   Reply With Quote
Old 06-19-2004, 02:14 AM   #4
Momotaro
Doesn't like Kool-Aid
 
Momotaro's Avatar
 
PTrader: (52/100%)
Join Date: Feb 2003
Location: Hawthorne, New Jersey
Posts: 10,125
Default

Things can be like that sometimes Shay!

My experiences in life have taught me that you can't be too quick to give up on something!

In situations like you experienced, sometimes it is best to just take a second, take a step back, and then try it again. Who knows, the filter might not have primed properly or, more likely, it might have been airlocked.

Either way, I am glad you got it all sussed out!

Mike
__________________
[SIGPIC][/SIGPIC]
Momotaro is offline   Reply With Quote
Old 06-19-2004, 03:13 AM   #5
sn8k
Planted Member
 
sn8k's Avatar
 
PTrader: (0/0%)
Join Date: May 2004
Location: SFO East Bay Area
Posts: 270
Default

Yeah, sometimes the impeller just gets very slightly out of kilter (off-center) and will give you the same indication (sound) that you would have if the shaft was broken. Same thing when you get an air lock - hard to say what the real problem was. Happened to my old Fluval all of the time... glad to see you got it all sorted out
__________________
Mark K...
Eheim Pimp Club Member #37

Custom All Glass 90 Gal (48x14x30) - Eheim 2028 Pro II - 8w AquaUV Sterilizer - 48" Aqualight 2-65W 6700K & 2-55W 9325K - (4) 3/4Watt Aqualight Lunar Blue-Moon-Glow LEDs - 160lbs EcoComplete substrate - Dupla Therm 500 substrate heater w/Temp Control - Hydor ETH300 inline heater - pressurized Co2 w/pH controller - Reactor 1000 CO2 - & lots of other misc. crap
sn8k is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Official Eheim Pimp Club Registration Momotaro Equipment 1182 07-02-2014 09:39 PM
Eheim or potential Eheim users in Australia rumples riot General Planted Tank Discussion 5 05-03-2010 07:25 PM
Those who want to join the Eheim Pimps Club rumples riot Equipment 20 04-21-2004 02:03 AM
Planted Tank Chat Transcripts! KyleT General Planted Tank Discussion 0 02-26-2004 09:20 PM
eheim 2126 Pro2 theTick Equipment 3 02-01-2004 06:16 PM


All times are GMT. The time now is 06:19 PM.


Powered by vBulletin®
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright Planted Tank LLC 2012