Heater Problems
Planted Tank Forums
Your Tanks Image Hosting *Tank Tracker * Plant Profiles Fish Profiles Planted Tank Guide Photo Gallery Articles

Go Back   The Planted Tank Forum > Specific Aspects of a Planted Tank > Equipment


Reply
 
Thread Tools Display Modes
Old 12-26-2002, 02:38 PM   #1
EJSwanny
Algae Grower
 
PTrader: (0/0%)
Join Date: Oct 2002
Location: Chicago land
Posts: 23
Default

I had a 200W submersible heater in my 46G for over 2 months when suddenly it just stopped working. I noticed cracks in the glass also. I replaced it with another 200W submersible (Tronic) last week and the light turned on for a few minutes but never came back on. I returned that one and it worked for 4 days till yesterday.

I saw no cracks in the first Tronic nor do I in the one I have now but there is no pilot light and the temp dropped drastically from 78 to 70 since yesterday. Only thing I can think of is that possible my Hornwort plants had been touching it too much. Any of you ever have problems like this?
EJSwanny is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 12-26-2002, 03:35 PM   #2
SNPiccolo5
Planted Tank Enthusiast
 
SNPiccolo5's Avatar
 
PTrader: (0/0%)
Join Date: Oct 2002
Location: Minneapolis, MN
Posts: 859
Default

My friend has had the opposite problem with a heater where the heater kept turning on too much so it made the water 90+ degrees. I really don't know what would be causing it, but I have never had a problem with any of my Ebo Jager heaters, so I would reccomend that one.

-Tim
__________________
Tank in transition! 55 gallons, hard water.
SNPiccolo5 is offline   Reply With Quote
Old 12-26-2002, 06:56 PM   #3
cramramdon
Algae Grower
 
PTrader: (0/0%)
Join Date: Jul 2002
Posts: 48
Default

I've never owned a Tronic, but I can add that ebo Jaggers seem to be the way to go. I have Ebo's on all my tanks and their constant and reliable. Theres good prices for them at www.BigAlsOnline.com
__________________
can your conscience bear the strain of all the pain that makes your food
cramramdon is offline   Reply With Quote
Old 12-26-2002, 08:33 PM   #4
m.lemay
Planted Tank Guru
 
m.lemay's Avatar
 
PTrader: (9/100%)
Join Date: Jul 2002
Location: Naugatuck, CT.
Posts: 2,647
Default

Ebo-Jager is one of the best if not the best. I have one in my 75 Gal thats about 7 yrs old and still working like a champ.
m.lemay is offline   Reply With Quote
Old 12-27-2002, 03:12 PM   #5
EJSwanny
Algae Grower
 
PTrader: (0/0%)
Join Date: Oct 2002
Location: Chicago land
Posts: 23
Default

Guess I'll have to go Ebo-Jagger. Thanks all
EJSwanny is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Submerge Ebo Heater ? YankeeFanInPA Equipment 8 09-18-2004 02:18 PM
Problems with AquaMedic/Eheim hook up- wonder woman Equipment 13 06-18-2004 12:08 AM
Hiding heater behind wall at back of tank? Derek Equipment 5 01-23-2004 05:33 PM
Heater Woes! mattrmiller Equipment 4 10-01-2003 12:05 AM
out of tank heater mr hyde Equipment 10 08-20-2003 02:30 PM


All times are GMT. The time now is 04:59 AM.


Powered by vBulletin®
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright Planted Tank LLC 2012