GH Booster- plants not so good
Planted Tank Forums
Your Tanks Image Hosting *Tank Tracker * Plant Profiles Fish Profiles Planted Tank Guide Photo Gallery Articles

Go Back   The Planted Tank Forum > General Planted Tank Forums > General Planted Tank Discussion


Reply
 
Thread Tools Display Modes
Old 05-14-2013, 04:21 AM   #1
Leebee
Algae Grower
 
PTrader: (0/0%)
Join Date: Apr 2012
Location: Australia
Posts: 51
Default

GH Booster- plants not so good


I have been adding a tropical water conditioner to my tank lately, as my tap water is very low in GH(20ppm). Since doing this I have noticed that some of the plants are not looking the best. The additive is for raising GH with 9 different salts,(5gms per 15litres of water raises hardness by 80ppm, and adds 130ppm of sodium chloride)!!. I am wondering if this is the problem, as it is often said that plants donít like this salt. I have some Seachem Equilibrium, which states it has no sodium chloride, and is for use in planted tanks. Should I change to the Equilibrium ?
__________________
Lee
Leebee is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 05-14-2013, 05:52 AM   #2
Diana
Planted Tank Guru
 
PTrader: (0/0%)
Join Date: Jan 2010
Location: Contra Costa CA
Posts: 8,284
Default

Absolutely! Do as big a water change as you can to get rid of the sodium chloride. The 'conditioner' you are using is not a good one for any fresh water tank. Neither fish nor plants like the salt.

I have used Seachem Equilibrium for a long time for certain tanks, and never had a problem.
Diana is offline   Reply With Quote Quick reply to this message
Old 05-14-2013, 10:37 PM   #3
Leebee
Algae Grower
 
PTrader: (0/0%)
Join Date: Apr 2012
Location: Australia
Posts: 51
Default

Thanks Diana, I'll give the equilibrium a go next water change.
__________________
Lee
Leebee is offline   Reply With Quote Quick reply to this message
Old 05-15-2013, 12:44 PM   #4
jbrady33
Wannabe Guru
 
jbrady33's Avatar
 
PTrader: (14/100%)
Join Date: Jun 2012
Location: Mt Laurel, NJ
Posts: 1,585
Default

my plants really seen to like Equilibrium, but I'm only using it in my 36 as I was warned that it may be causing me issues with Crystal Shrimp in my little 3 gallon (switching to Fluval shrimp mineral for that tank)
__________________
jbrady33 is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the The Planted Tank Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 07:42 AM.


Powered by vBulletin®
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright Planted Tank LLC 2012