Yellow Leaves on Hygrophila Polysperma
Planted Tank Forums
Your Tanks Image Hosting *Tank Tracker * Plant Profiles Fish Profiles Planted Tank Guide Photo Gallery Articles

Go Back   The Planted Tank Forum > Specific Aspects of a Planted Tank > Plants


Reply
 
Thread Tools Display Modes
Old 04-05-2013, 09:17 AM   #1
Cormorin
Algae Grower
 
PTrader: (0/0%)
Join Date: Mar 2013
Location: UK
Posts: 36
Exclamation

Yellow Leaves on Hygrophila Polysperma


Hi,

I have a 15g tank with 17neon tetra, 2rainbow, 2dwarf gourami and a hang on filter with spong and charcoal.

I do a 1/3 water change every two weeks and my nitrite 0 and nitrate 15.

I only have a gravel substrate but use a plant feed each week as a supplement.

There is a 15w k18,00 bulb on 12hrs a day.

My problem is I bought Hygrophila two days ago very green and lush and now kits starting to drop leaves and look yellow and limp at the top of the plant. Other plants seem to be doing ok. See photos.

Oh temp is about 25deg.

Any advise would be great.

Last edited by Cormorin; 04-05-2013 at 10:07 AM.. Reason: Notification setting
Cormorin is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 04-05-2013, 09:18 AM   #2
Cormorin
Algae Grower
 
PTrader: (0/0%)
Join Date: Mar 2013
Location: UK
Posts: 36
Default Photo

Please see photo related to the above.
Attached Thumbnails
Click image for larger version

Name:	image.jpg
Views:	28
Size:	81.9 KB
ID:	119818  

Cormorin is offline   Reply With Quote Quick reply to this message
Old 04-05-2013, 10:55 AM   #3
acitydweller
ओं मणिपद्मे हूं
 
acitydweller's Avatar
 
PTrader: (177/100%)
Join Date: Dec 2011
Location: New York
Posts: 7,695
Default

I absolutely love this plant as it is rather non fussy about anything.

This may be a condition in lack of phosphate or potassium. Another possibility is having extremely hard water.

hope the link here proves useful.
__________________
"I am Groot", the faithful protector
acitydweller is offline   Reply With Quote Quick reply to this message
Old 04-05-2013, 11:07 AM   #4
OVT
Carpe Diem
 
OVT's Avatar
 
PTrader: (142/100%)
Join Date: Nov 2011
Location: SF East Bay Area
Posts: 5,184
Default Re: Yellow Leaves on Hygrophila Polysperma

It could be adjusting to the new environment. As with any Hygro, adding root tabs will go a long way to keep it healthy.
__________________
Courtesy * Integrity * Perseverance * Indominable Spirit * and Self Control
Tenets of TKD
OVT is offline   Reply With Quote Quick reply to this message
Old 04-05-2013, 12:58 PM   #5
Cormorin
Algae Grower
 
PTrader: (0/0%)
Join Date: Mar 2013
Location: UK
Posts: 36
Default

Hi - I just spoke with the guy who sold the plants and he suggest much the same. As they have only been in the tank 3 days he suggest waiting a week before taking any action to see if they settle in, chemicals or additives should be a last resort.
Cormorin is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the The Planted Tank Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 10:31 AM.


Powered by vBulletin®
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright Planted Tank LLC 2012