DISCUS..pls help. - Page 2
Planted Tank Forums
Your Tanks Image Hosting *Tank Tracker * Plant Profiles Fish Profiles Planted Tank Guide Photo Gallery Articles

Go Back   The Planted Tank Forum > Specific Aspects of a Planted Tank > Fish


Reply
 
Thread Tools Display Modes
Old 02-15-2013, 05:07 PM   #16
discuspaul
Planted Tank Guru
 
discuspaul's Avatar
 
PTrader: (0/0%)
Join Date: Jul 2010
Location: British Columbia, Canada
Posts: 2,157
Default

Your water params look ok.
What has happened in your tank since your last posting in early January, about a month & a half ago ?
Did you keep up the large, frequent wcs, and the tank cleaning routine ?
How are your discus doing now ?
Fill us in.
discuspaul is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 02-15-2013, 05:10 PM   #17
CPDzeke
Planted Tank Enthusiast
 
CPDzeke's Avatar
 
PTrader: (4/100%)
Join Date: Jan 2013
Location: Minnesota
Posts: 960
Default

Too bad you don't know the owner of my lfs...

He is an absolute discus freak and him and his brother do water changes like twice a week. I think he would know.
__________________
ADA Gentleman #1
Treeless Mountain V3
CPDzeke is offline   Reply With Quote
Old 02-15-2013, 05:16 PM   #18
CrypticLifeStyle
Wannabe Guru
 
PTrader: (8/100%)
Join Date: Jan 2013
Location: Boston
Posts: 1,223
Default

Was that 0 nitrates I saw?
__________________
I'm not into the image, but into the hobby...
CrypticLifeStyle is offline   Reply With Quote
Old 02-16-2013, 01:28 AM   #19
NoObLet
Planted Member
 
NoObLet's Avatar
 
PTrader: (3/100%)
Join Date: Apr 2007
Location: Bay Area.CA.
Posts: 236
Send a message via AIM to NoObLet
Default

i think it could have been me cleaning out my filter. i didn't save much of the media like i should have. So i think it may be a cycling problem?
__________________


PayPal Verified
NoObLet is offline   Reply With Quote
Old 02-20-2013, 07:03 AM   #20
jl209
Planted Member
 
PTrader: (1/100%)
Join Date: Mar 2006
Location: Modesto,ca
Posts: 240
Default

The oily film on the surface of your water indicates a high level of dissolved organis in your water. In other words your tank is dirty. Do the reccomended w/c running some activated carbon in your filters will also help. Dont forget the wipe down and gravel vac.
jl209 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 08:39 AM.


Powered by vBulletin®
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright Planted Tank LLC 2012