Hagen Customer service experiences? My Ebi issue
Planted Tank Forums
Your Tanks Image Hosting *Tank Tracker * Plant Profiles Fish Profiles Planted Tank Guide Photo Gallery Articles

Go Back   The Planted Tank Forum > General Planted Tank Forums > General Planted Tank Discussion


Reply
 
Thread Tools Display Modes
Old 01-08-2014, 06:41 PM   #1
DTDPlanted
Planted Member
 
DTDPlanted's Avatar
 
PTrader: (2/100%)
Join Date: Apr 2012
Location: Port Saint Lucie, FL
Posts: 293
Question

So my Ebi arrived yesterday and from the long history of background adhesion stories and a visual inspection from myself I thought it best to play it safe and re-attach the background more firmly myself. I went about searching on the best way to do it when I came across a forum thread from a few years back stating when people had this issue Hagen was sending some aquarium sealant so they could re-apply the background. Everyone was claiming a no questions asked and extremely helpful attitude from the CSRs. When I called called Hagen today I got the "send it back to amazon for a replacement or DIY" response. No offer to send me some sealant even when I asked if they could just send some....I have had pleasant dealings with Hagen in the past but this is starting to leave a bad taste in my mouth. I just dont think I should have to pay $7-12 to fix a problem with the tank that Hagen has known about for years. Does anyone have any current experiences with warranty replacement, Ebi specific would help. I will be submitting an email and complaining about the issue as well for good measure, maybe I can make something happen

http://www.bcaquaria.com/forum/equip...n-alert-12248/

That is the forum post where they discuss getting the silicon from Hagen

Bump, I sent an email. We will see what they come up with. I filled the tank with tap water to see what would happen and confirmed that about 5 of the 10 dots were actually holding the background, the others are all just stuck to the tank

Last edited by Darkblade48; 01-09-2014 at 03:20 AM.. Reason: Back to back posts
DTDPlanted is online now   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 01-08-2014, 11:24 PM   #2
jrh
Planted Tank Enthusiast
 
PTrader: (14/100%)
Join Date: Sep 2007
Location: Alexandria, VA
Posts: 588
Default

I haven't dealt with them RE the background, but the early models had lights that would often burn out after 1-3 months, and they replaced my light fixture. I think I just emailed them a picture of the receipt.
jrh is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the The Planted Tank Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 09:24 AM.


Powered by vBulletin®
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright Planted Tank LLC 2012