Anubias/Val Advice
Planted Tank Forums
Your Tanks Image Hosting *Tank Tracker * Plant Profiles Fish Profiles Planted Tank Guide Photo Gallery Articles

Go Back   The Planted Tank Forum > General Planted Tank Forums > General Planted Tank Discussion


Reply
 
Thread Tools Display Modes
Old 10-21-2012, 06:57 PM   #1
LouiC
Algae Grower
 
PTrader: (0/0%)
Join Date: Oct 2012
Location: Winnipeg
Posts: 16
Default

Anubias/Val Advice


Hi,

I have an african cichlid setup with various anubias and vallisneria americana. I've been having trouble with both plants seemingly for different reasons. The anubias is struggling with what I'm guessing is algae spots and the vals are disintegrating. I have a few pictures at the end of this post to try and show what I mean.

I'm wondering if the high spectrum of my bulbs is causing the algae growth and I'm wondering if CO2 injection will help or hinder? I would try flourish excel, but I've read that excel and vals don't mix. I really have no idea why the vals aren't doing well.

My Specs: 60g tank, 2 18" T8 15W 1800K (Power-Glo) Bulbs, 13 3-5" cichlids and sand substrate. My pH is 7.4, NH3, NO2 are 0ppm and NO3 never gets over 5ppm. I am dosing with Flourish Comprehensive once a week.

Plants:
anubias:
coffeefolia
hastifolia
barteri
nana
vallisneria americana



LouiC is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 10:34 AM.


Powered by vBulletin®
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright Planted Tank LLC 2012