Eheim classic, easy to prime?
Planted Tank Forums
Your Tanks Image Hosting *Tank Tracker * Plant Profiles Fish Profiles Planted Tank Guide Photo Gallery Articles

Go Back   The Planted Tank Forum > Specific Aspects of a Planted Tank > Equipment


Reply
 
Thread Tools Display Modes
Old 03-20-2005, 06:06 PM   #1
khoile
Planted Tank Enthusiast
 
PTrader: (1/100%)
Join Date: Jan 2005
Location: OC, CA, US
Posts: 619
Default

Eheim classic, easy to prime?


Hi, I'm considering getting an Eheim classic, the cheapest one, just need to know how easy is it to prime? I don't want to spend 30 min just to prime a filter. What about the Ecco? how is that compare to classic?


Thanks.
khoile is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 03-20-2005, 10:03 PM   #2
Raul-7
Wannabe Guru
 
Raul-7's Avatar
 
PTrader: (4/100%)
Join Date: Oct 2003
Location: Lomita, CA
Posts: 1,698
Default

All you need to do is fill the canister with water, and plug it in. But make sure the both the input and output are both underwater. To make your life much easier you can buy the priming bulb for $11 which you can use to pump water manually into the canister, this also prevents annoying air bubbles from being trapped inside the canister.

As for Classics vs Ecco. Classics are a superior and proven. Classics are much powerful, reliable(some people have 25 year old canisters still in good shape), they have a spraybar, and are much quieter than the Ecco's.
Raul-7 is offline   Reply With Quote Quick reply to this message
Old 03-21-2005, 01:10 AM   #3
John P.
Wannabe Guru
 
John P.'s Avatar
 
PTrader: (3/100%)
Join Date: Apr 2004
Location: Laguna Beach, CA
Posts: 1,321
Default

Classics are easy to prime, service, own. I'd never buy a different canister filter.
__________________
John P.
John P. is offline   Reply With Quote Quick reply to this message
Old 03-21-2005, 08:44 AM   #4
spleen93
Algae Grower
 
PTrader: (0/0%)
Join Date: Jan 2005
Location: USA
Posts: 20
Default

Raul - FWIW, my Ecco is silent. Can't imagine how a Classic could be quieter than my Ecco (can't get quieter than silent). I have to watch the plants swaying in the output stream to tell it's running.

Spleen
spleen93 is offline   Reply With Quote Quick reply to this message
Old 03-21-2005, 01:44 PM   #5
cbl
Algae Grower
 
PTrader: (0/0%)
Join Date: Mar 2005
Location: Ohio
Posts: 10
Default

If what Raul-7 says doesn't work, then I'd do the following:

With an empty filter, after cleaning it, what i usually do is to have the filter empty with the intake and output tubing pointed upward. However with the intake tubing in the tank in the water and suck some air through the output tubing. You should start seeing water trickle down the intake tube and filling up the filter nicely. Water pretty much start filling up the filter till it's as high as the water level. Once that's done put the output tubing back in the tank...hang it what not, turn on the power.

Or of course, you can always get a suction ball.




Quote:
Originally Posted by spleen93
Raul - FWIW, my Ecco is silent. Can't imagine how a Classic could be quieter than my Ecco (can't get quieter than silent). I have to watch the plants swaying in the output stream to tell it's running.

Spleen
__________________
-------------------------
| Eheim Pimp #130 |
-------------------------
cbl is offline   Reply With Quote Quick reply to this message
Old 03-21-2005, 03:32 PM   #6
GraFFix
Planted Member
 
GraFFix's Avatar
 
PTrader: (1/100%)
Join Date: Feb 2005
Location: N.W. Chicago
Posts: 277
Default

Seeing as how I just set my first Eheim filter up a few days ago i thought i would give my 2 cents.
The first time you setup the filter is the only time where priming is going to be an issue...As long as you use the quick discconects when you setup the filter, priming will happen automatically.

What I did is setup the filter with the quick disconnects..i have mine about 12" below the intake/return pipe. Now the first time you have no water in the hoses...so what I did might not be the easiest way but it worked like a charm for me. grab the intake side hose and seperate the quick disconnects...now holding the top part slowly start a syphon (i used my mouth) but when you start seeing water hurry up and close the valve on the quick disconnect...now you should have water just in the top part of the tubing. after that put the quick disconnects back together and then just open up the valve. When you open the valve up the water will start the rest of the syphon for you which in turn will continue to fill up the canister...push all the air bubbles out and be ready to plug in in 30 seconds.
Now after you have the unit primed and water is running through the tubing...when you have to clean the filter or whatever. close the valves on the quick disconnects then unplug the filter...this will leave water in that top intake hose again. After cleaning, connect the quick disconnects again and just open the valves...the syphon will be done for you again...its pretty easy.
GraFFix is offline   Reply With Quote Quick reply to this message
Old 03-21-2005, 05:43 PM   #7
TeeItUp
Planted Tank Obsessed
 
TeeItUp's Avatar
 
PTrader: (0/0%)
Join Date: Mar 2004
Location: Mount Vernon, Ohio
Posts: 493
Default

Quote:
Originally Posted by John P.
Classics are easy to prime, service, own. I'd never buy a different canister filter.
I agree. I have a 2215 and to prime new I simply connect everything as shown. The remove at the quick fitting the return line. Suck a little on the canister side and re-connect. If both valves are open the filter will fill by siphoning in from the tank inlet. When you here is burp out the spray bar simply turn it on. When cleaning my filter now there is no need to suck the prime because when you shut off the valves water remains in the line. Open the inlet valve first then the return and it fills.
__________________
Eheim Pimp Club member #14
2215 Classic
Eheim CO2 Diffuser
TeeItUp is offline   Reply With Quote Quick reply to this message
Old 03-21-2005, 06:59 PM   #8
ringram
Planted Tank Guru
 
ringram's Avatar
 
PTrader: (66/100%)
Join Date: Jan 2005
Location: West Sacramento, CA
Posts: 2,600
Send a message via AIM to ringram
Default

I have an Eheim cannister(classic #2222) and it is very easy to operate. I simply flip the flow control(in/out) to "off" when I am servicing the tank --- water changes, cleaning filter, etc. When I am ready I just turn it back to "on" and the siphon starts up. The only problem I have encountered is when there is not enough water in the filter to start the siphon --- this isn't really a problem, but just a reality. I have not had any real problems with this filter and think its great!
__________________
90g journal: http://www.plantedtank.net/forums/ph...rnal-pics.html
---------------------------------------------------
SFBAAPS member - http://www.sfbaaps.com/

SAPS member - http://groups.yahoo.com/group/sacaquaticplant/
ringram is offline   Reply With Quote Quick reply to this message
Old 03-21-2005, 11:17 PM   #9
Momotaro
Doesn't like Kool-Aid
 
Momotaro's Avatar
 
PTrader: (52/100%)
Join Date: Feb 2003
Location: Hawthorne, New Jersey
Posts: 10,125
Default

After the initial prime, you should never have to worry about priming the filter again. You can easily do it without filling the canister or have to re establish any suction. From the Eheim service instructions by Phyllis Ringstad from Vicki Costley:

Quote:
When youíre done (cleaning the media and pads), take the filter back, hook up the double taps, open the bottom valves first and then the top valves. The filter should fill up again on its own (no need to start the siphon manually). When itís full, plug it in. Youíre done.
Follow these simple instructions and you will never have a problem. Just be sure the spraybar is under the surface of the water!

Mike
__________________
[SIGPIC][/SIGPIC]
Momotaro is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the The Planted Tank Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 02:31 PM.


Powered by vBulletin®
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright Planted Tank LLC 2012