zebra snail
Planted Tank Forums
Your Tanks Image Hosting *Tank Tracker * Plant Profiles Fish Profiles Planted Tank Guide Photo Gallery Articles

Go Back   The Planted Tank Forum > General Planted Tank Forums > General Planted Tank Discussion


Reply
 
Thread Tools Display Modes
Old 09-22-2011, 03:31 AM   #1
Venus85
Algae Grower
 
PTrader: (0/0%)
Join Date: Aug 2011
Location: Corona,California
Posts: 33
Default

zebra snail


anyone know what this black crap is coming from my zebra snail?Ever since i put it in my tank it has been leaving this mess of black substance next to my drift wood.its been grazing i guess on my drift wood for a while and it hasnt even cleaned this green algae im trying to get rid of thats growing on my sand.Its getting frustrating now.I recently upgraded my lighting and was hoping for the best.any help will be appreciated
Venus85 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 09-22-2011, 04:07 AM   #2
kamikazi
Planted Tank Guru
 
kamikazi's Avatar
 
PTrader: (5/100%)
Join Date: Sep 2010
Location: Lincolnton, NC
Posts: 2,245
Default

poop!

what kind of green algae is on your sand.
kamikazi is offline   Reply With Quote
Old 09-22-2011, 04:48 PM   #3
Venus85
Algae Grower
 
PTrader: (0/0%)
Join Date: Aug 2011
Location: Corona,California
Posts: 33
Default

the sediment kind thats spreads
Venus85 is offline   Reply With Quote
Old 09-22-2011, 05:48 PM   #4
tener
Algae Grower
 
PTrader: (0/0%)
Join Date: May 2010
Location: uk
Posts: 69
Default

its snail poo,ive got 4 in my 75L.they do a great jod of cleaning up the walls,filter etc.
i did have one in my edge but cleaning up the poo was a pain in butt.
he now lives in the bigger tank.
tener is offline   Reply With Quote
Old 09-22-2011, 07:05 PM   #5
Venus85
Algae Grower
 
PTrader: (0/0%)
Join Date: Aug 2011
Location: Corona,California
Posts: 33
Default

o ok.i also had a crypt wendtii that melted away.it just turned clear and died.i havent pulled out the roots yet.I dose flourish potassium,florapride(fertilizer),flourish excel and i use yeast and sugar to make my own co2.any idea why the c wendtii died?
Venus85 is offline   Reply With Quote
Old 09-22-2011, 07:36 PM   #6
kamikazi
Planted Tank Guru
 
kamikazi's Avatar
 
PTrader: (5/100%)
Join Date: Sep 2010
Location: Lincolnton, NC
Posts: 2,245
Default

sediment kind that spreads? never heard of this algae. do you have a picture of it?

plants will sometimes melt when trying to make the transition from emmersed to submerged growth. also crypts can melt from suddenly introducing full doses of Excel or higher levels of excel.
kamikazi is offline   Reply With Quote
Old 09-22-2011, 09:14 PM   #7
BradH
Planted Tank Enthusiast
 
PTrader: (13/100%)
Join Date: May 2008
Location: Nashville, TN
Posts: 914
Default

Are you talking about cyanobacteria spreading on your substrate? If so you're snail is not going to eat it.
BradH is offline   Reply With Quote
Old 09-23-2011, 01:36 AM   #8
tbarabash
Planted Tank Obsessed
 
PTrader: (0/0%)
Join Date: May 2011
Location: Edmonton AB Canada
Posts: 353
Default

Quote:
Originally Posted by Venus85 View Post
o ok.i also had a crypt wendtii that melted away.it just turned clear and died.i havent pulled out the roots yet.I dose flourish potassium,florapride(fertilizer),flourish excel and i use yeast and sugar to make my own co2.any idea why the c wendtii died?
That's just crypt rot. Google it if you're curious. Crypts are just sensitive to... everything really, even moving them a couple inches in your tank can piss them off and they'll just melt away. Leave the roots and the rhizome in the substrate though and they'll eventually grow back. I planted 4 crypt plants that I took out of my edge into my ebi when I got it and they all melted but after about a month they started regrowing and now are poking through the substrate.
tbarabash is offline   Reply With Quote
Old 09-23-2011, 02:49 AM   #9
Venus85
Algae Grower
 
PTrader: (0/0%)
Join Date: Aug 2011
Location: Corona,California
Posts: 33
Default

alright ill just leave them in there.i dont think its cyanobacteria.its just green algae
Venus85 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 01:26 PM.


Powered by vBulletin®
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright Planted Tank LLC 2012